Jump to content

Recommended Posts

look up the error and you will get your answer.. whenever you have something you want to do the first thing you should do is look up the error if it isn't already obvious.

Once you do that you will find which command you should type.. if that command gives an error.. repeat..

until done..

  • Love 1

look up the error and you will get your answer.. whenever you have something you want to do the first thing you should do is look up the error if it isn't already obvious.

Once you do that you will find which command you should type.. if that command gives an error.. repeat..

until done..

yes i trying but the same error cant upgrade pkg8

 

First don't forget to update your system and your ports:

 

freebsd-update fetch install

portsnap fetch update

 

Then:

 

/usr/sbin/pkg
pkg2ng

 

thanks but  /usr/bin/pkg update comand not found i must update pkg to version 1.3.8

 

then:

 

cd /usr/ports/ports-mgmt/pkg
make install clean

 

 

i got error 

Screen_Shot_09_25_14_at_02_57_PM.jpg

 

ok thanks Shogun i use reinstall

Edited by Metin2 Dev
Core X - External 2 Internal

but this still not worknig Screen_Shot_09_26_14_at_05_47_PM.jpg

 

solved

don't mark it as solved and leave. Explain the situation

 

We spent our time and effort to help you, don't just disappear like that. someone else may want to see this in the future.

Edited by Metin2 Dev
Core X - External 2 Internal
  • Love 1

 

but this still not worknig Screen_Shot_09_26_14_at_05_47_PM.jpg

 

solved

don't mark it as solved and leave. Explain the situation

 

We spent our time and effort to help you, don't just disappear like that. someone else may want to see this in the future.

 

i forget add you lib mysqlclient18.so to lib32 and work fine.

Edited by Metin2 Dev
Core X - External 2 Internal
  • 1 month later...

on FreeBSD 10.0 64bit the command to start mysql is no longer start... it's 

services mysql-server onestart

Instead of 

services mysql-server start

and the command pkg_add / pkg_delete are no longer available (for installing compatx7)

  • 1 month later...

im trying put this work on a VirtualBox with FreeBSD 9.3 version i389, I already did almost every step, but i cant log via FTP with root account, i create right now a new account called metin2 to test, and with metin2 account i can access via ftp but with root account i cant

>>SOLVED<<

 

I have a problem with the root password .... not change. I start the mysql-server service (How you see in the picture). I have no idea how to solve this problem.

 

 

BAu4zJY.png

 

 

EDIT: The solution to this problem is:

mysql -u root -p
nuevapass

GRANT ALL PRIVILEGES ON *.* TO root@'%' IDENTIFIED BY 'nuevapass';
FLUSH PRIVILEGES;

nuevapass is the password that you assigned to root

Edited by Metin2 Dev
Core X - External 2 Internal
  • Love 1

Hi,

 

i'have serious problem:
 

AUTH_SERVER: I am the master
~~~> VANILLA project rev54250 <~~~
socket_tcp_bind: tcp_socket: Can't assign requested address, in all core, i can't fix it, please, help me.

Your Sincerily
  • 2 weeks later...

hot tow  fix?

 

for:

 

Warning: Using a password on the command line interface can be insecure.
 

i did not underestand

 

Originally Posted by Stackoverflow
If your MySQL client/server version is a 5.6.x a way to avoid the WARNING message are using the mysql_config_editor tools:

mysql_config_editor set --login-path=local --host=localhost --user=username --password

Then you can use in your shell script:

mysql --login-path=local -e "statement"

instead of:

mysql -u username -p pass -e "statement"

 

sorry bad english

 

im trying put this work on a VirtualBox with FreeBSD 9.3 version i389, I already did almost every step, but i cant log via FTP with root account, i create right now a new account called metin2 to test, and with metin2 account i can access via ftp but with root account i cant

 

I believe you need to install an ftp server for this.

 

 

>>SOLVED<<

 

I have a problem with the root password .... not change. I start the mysql-server service (How you see in the picture). I have no idea how to solve this problem.

 

 

BAu4zJY.png

 

 

EDIT: The solution to this problem is:

mysql -u root -p
nuevapass

GRANT ALL PRIVILEGES ON *.* TO root@'%' IDENTIFIED BY 'nuevapass';
FLUSH PRIVILEGES;

nuevapass is the password that you assigned to root

 

 

Thankyou for adding the solution instead of just leeching the community. Much appreciated.

 

 

Hi,

 

i'have serious problem:

 

AUTH_SERVER: I am the master
~~~> VANILLA project rev54250 <~~~
socket_tcp_bind: tcp_socket: Can't assign requested address, in all core, i can't fix it, please, help me.

Your Sincerily

 

 

This is not an issue specific to running metin2 on freebsd. The base setup is here, but Vanilla core requires special things.

Edited by Metin2 Dev
Core X - External 2 Internal
  • Premium

im trying put this work on a VirtualBox with FreeBSD 9.3 version i389, I already did almost every step, but i cant log via FTP with root account, i create right now a new account called metin2 to test, and with metin2 account i can access via ftp but with root account i cant

 

You need to change in /etc/ssh/sshd_config

 

PermitRootLogin yes

boas,

Segui todos os passos umas 30x nos ultimos 4 dias.... o resultado é sempre o mesmo:

 

erro.jpg

 

 

 

estou a usar um dedicado FreeDBS 9.3 na soyoustart

 

 

alguem pode dar uma ajuda?

Edited by Metin2 Dev
Core X - External 2 Internal

Shogun... : 

 

isto não faz os updates.... Ja instalei a máquina e formatei mais de 30x. Ja fiz tudo e mais alguma coisa.

Segundo vi na net, tinha de fazer o "mysql_upgrade" apos a instalação do mysql e ja fiz... ja fiz antes, depois,.... nem sei :

 

o erro é sempre esse. Se eu tentar fazer o mysql_upgrade apos copiar a minha db para o dedicado, aparece a dizer que:

 

 

Looking for 'mysql' as: mysql
Looking for 'mysqlcheck' as: mysqlcheck
FATAL ERROR: Upgrade failed

 

 

não faço ideia de todo :

Looking for 'mysql' as: mysql
Looking for 'mysqlcheck' as: mysqlcheck
FATAL ERROR: Upgrade failed
 
 
 
 
resolvido xD
 
 
solução: mysql_upgrade -S /tmp/mysql.sock -uUSERNAME -p
 

Don't use any images from : imgur, turkmmop, freakgamers, inforge, hizliresim... Or your content will be deleted without notice...
Use : https://metin2.download/media/add/

Please use https://metin2.download/ when uploading files smaller than 100MB, otherwise the approval will take longer due to manual upload.

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now
×
×
  • Create New...

Important Information

Terms of Use / Privacy Policy / Guidelines / We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.