Jump to content
Sign in to follow this  
Jfirewall

[Dif] Internal IP Fix r40250

Recommended Posts

Dif:

This difference file is created by The Interactive Disassembler



game_r40250

000A0C34: 80 90

000A0C4D: 80 90

000A0CD9: 80 90

002169F3: 80 90

00216A18: 80 90

Sorry!, I use translator the diff makes you never kick to login also add to our start.sh

 

add a to start.sh

 

where this ./game &

add  ./game  -I 123.123.123 -P 13000 &

-i = ip to server

 

p = Port server

 

you should add me in chanel 99 

 

channels only 

 

Example:

 

echo -e "033[31m Iniciando Database ..033[0m"
cd ./g1/db/
rm -rf syserr syslog
./db &
./auto.sh &
sleep 2
clear
echo -e "033[31m n Iniciando Auth ..033[0m"
cd ../auth 
rm -rf syserr syslog
./auth &
./auto.sh &
sleep 2
clear
echo -e "033[31m n 1. Iniciando Canal...033[0m"
cd ../../channel1/
./auto.sh &
./game  -I 123.123.123.123 -P 13000 &
sleep 2
echo -e "033[31m n Iniciando Canal 99 ..033[0m"
cd ../game99/
./auto.sh &
./game  -I 123.123.123.123 -P 13000 &
sleep 2

 

funciona al 100% used it in a while and always wanted to serve me and I Enjoy it Share.

 

guide made ​​by me 

 

pd: my original language is Spanish.

 

greeting

  • Love 3

Share this post


Link to post

Maybe source code too?
Thanks in advance.
PS. What do u mean by saying "never kick to login"? Packets error or sequence?

Share this post


Link to post
no source just because the other got the diff I did, I have the antilogin off for all versions of game so it's nothing new. 
 
if you have errors that is another thing that it does is that once inside you never leave, as many servers each time they got back to logearte this is the solution.

Share this post


Link to post

Maybe source code too?

Thanks in advance.

PS. What do u mean by saying "never kick to login"? Packets error or sequence?

 

Internal IP fix made by MartPwnS for this game revision.

Share this post


Link to post

Topic title edited to avoid confusion. Is this dif made by you?

Share this post


Link to post

me vota conection refused :( se pone la ip .100 del hamachi o se pone la ip normal?

Share this post


Link to post

me vota conection refused :( se pone la ip .100 del hamachi o se pone la ip normal?

Se pone la ip publico ( normal )

  • Love 1

Share this post


Link to post

vota conection refused:S

y ademas si pongo .100 me vota ip ilegal y si pongo ip normal del hamachi me vota no found :/

Share this post


Link to post

really funny

 

just take bind_ip in config do not with thats so waste time

 

that just active your game bind_ip request

Share this post


Link to post

With these DIF my friends can login into my server hamachi 40k?

When I insert "-I 123.123.123.123 -P 13000" into start.sh, receive this error :tcp_socket: Can't assign requested address"

 

Sorry for my english.

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  
  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...

Important Information

Terms of Use / Privacy Policy / Guidelines / We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.