Jump to content
×
×
  • Create New...
  • 0

Vanilla Source


JollyPotato

Question

9 answers to this question

Recommended Posts

  • 0

I have now the problem :


g++49 -Wall -O2 -pipe -mcpu=i686 -fno-exceptions -fno-rtti -MM *.cc > Depend
g++49: warning: '-mcpu=' is deprecated; use '-mtune=' or '-march=' instead
cc1plus: error: CPU you selected does not support x86-64 instruction set
cc1plus: error: CPU you selected does not support x86-64 instruction set
cc1plus: error: CPU you selected does not support x86-64 instruction set
cc1plus: error: CPU you selected does not support x86-64 instruction set
cc1plus: error: CPU you selected does not support x86-64 instruction set
Makefile:29: recipe for target 'dep' failed
gmake[1]: *** [dep] Error 1
gmake[1]: Leaving directory '/root/workspace/mainline/libpoly'
Makefile:35: recipe for target 'libpoly' failed
gmake: *** [libpoly] Error 2
[email protected]:~/workspace/mainline #

 

Link to comment
Share on other sites

  • 0
  • Former Staff

the build-in GCC compiler (i think 4.x)  uses  '-mcpu' Flag 

but GCC 48+ uses '-mtune' or '-march'  Flags

but i don't know why he is using GCC he can use Clang

Edited by flygun
Link to comment
Share on other sites

  • 0

the build-in GCC compiler (i think 4.x)  uses  '-mcpu' Flag 

but GCC 48+ uses '-mtune' or '-march'  Flags

but i don't know why he is using GCC he can use Clang

Why to use clang, omg all of you use clang.

Fuck clang, gcc is better.

 

Until now all use gcc 2-3 months, now you can not hear any of gcc.
From my point of view is much better gcc.

  • Love 1
Link to comment
Share on other sites

  • 0
  • Former Staff

i use GCC (much much better) but i think he don't want to use the solution .. so ... plus he is using 10.1 freebsd which i think that clang is the default c compiler 

Edited by flygun
Link to comment
Share on other sites

  • 0

okay guys i install now freebsd 9.3 on local pc and now i want to make gmake and have now a another problem


gcc -Ofast -fomit-frame-pointer -g -march=i686 -msse4 -mssse3 -Wall -I../include      -c -o lapi.o lapi.c
cc1: error: invalid option argument '-Ofast'
cc1: error: unrecognized command line option "-msse4"
<builtin>: recipe for target 'lapi.o' failed
gmake[2]: *** [lapi.o] Error 1
gmake[2]: Leaving directory '/root/workspace/mainline/liblua/src'
Makefile:11: recipe for target 'all' failed
gmake[1]: *** [all] Error 2
gmake[1]: Leaving directory '/root/workspace/mainline/liblua'
Makefile:60: recipe for target 'all' failed
gmake: *** [all] Error 2

 

 

 

 

its the Makefile but i dont know what i do false i uploade my makefile ....

 

 

sory for the best english :D

JollyPotato

 

Makefile

 

Edited by JollyPotato
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


Important Information

Terms of Use / Privacy Policy / Guidelines / We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.