Jump to content
  • Join-Us

    https://metin2.dev is the 1st international community on Metin2 development. Join us to develop your skills and share your knowledge with the community, respectful and ethical forum.

  • 0

MySQL stop when start server


Aigo

Question

Sorry, maybe a noob question but now i dont know what to do. just installed the 40k reference files on a VPS and i was able to login in the game. Soo, i done another account and reboot. After that it looks like start fine but the mysql just stop. Even navicat cant enter, if i start the mysql service navicat can connect but the game dont. If i put a wrong account it say that id or password wrong but if i put the admin account it just tell connection error. Ive been looking on syserr and syslog from auth, channel1, db and game99 but nothing really clear. 

Link to comment
Share on other sites

4 answers to this question

Recommended Posts

  • 0

Ok soo, it looks like solved.

As you told me yesterday on pm; i decid to try using mysql55 instead mysql56. Soo, just followed these instruction:

Remove mysql8.x or other if you installed...

pkg install mysql55-server

rename/delete the default /var/db/mysql folder

service mysql-server stop

upload and extract the mysql folder to /var/db with tar -xf xymsql.tar.gz ( tar -xf did not work to me. So i used tar -zxvf )

service mysql-server start

(after this i had to make a reboot because navicat was showing old data, idk)

 

Also i had to edit ports on client files. Did not touch any ports from server side. Now the serverinfo.py looks like this.

PORT_1				= 13002
PORT_2				= 13010
PORT_3				= 13020
PORT_4				= 13030
PORT_AUTH			= 11000
PORT_MARK			= 13001

 

By now everything works fine. If want i can make a guide on how to install 40k reference files on a clean VPS. I can write it and send it to you soo you can improve or solve any mistake. 

 

Thaanks!

30 minutes ago, TMP4 said:

There are several possible solve case for that: 

This is the hidden content, please

(check especially for stackoverflow links)

Check the .log files next to the .err maybe it have some useful info.

Since I included tar.gz for mysql, did you extract that correctly with tar -xf command? Some people using winrar and so..

(I will probably include mysql dump soon to my reference sf because that is a better way to import the database but most people don't know what it is and looking for tar.gz from old tutorials...)

Just reinstalled mysql using 55 instead 56. Solved, thank you!

  • Metin2 Dev 1
Link to comment
Share on other sites

!-->
  • 0
  • Distinguished Member

If your mysql crashing/not starting then check the mysql's .err files, not the serverfile's syserr. It's in /var/db/mysql/*.err 

It always writes down what the reason is. 

  • Love 1
Link to comment
Share on other sites

  • 0

Thanks! I just deleted the .err file and run again the server. Again i had the same problem and the new err file say this.

210928 11:49:35 mysqld_safe mysqld restarted
210928 11:49:54 mysqld_safe mysqld from pid file /var/db/mysql/Metin2Test.pid ended

Also just found this topic. He say that the error is solved with service mysql-server restart. But did not work to me.

Spoiler

 

On this topic someone said about this solution. But the topic is from 2015 and im not sure if this solution is outdated.

Spoiler

Check etc/rc.conf delete 

mysql_args="--skip-grant-tables --skip-networking"

 if is and reboot.

 

Edited by Aigo
Link to comment
Share on other sites

  • 0
  • Distinguished Member

There are several possible solve case for that: 

This is the hidden content, please

(check especially for stackoverflow links)

Check the .log files next to the .err maybe it have some useful info.

Since I included tar.gz for mysql, did you extract that correctly with tar -xf command? Some people using winrar and so..

(I will probably include mysql dump soon to my reference sf because that is a better way to import the database but most people don't know what it is and looking for tar.gz from old tutorials...)

Edited by TMP4
  • Metin2 Dev 2
  • Good 1
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


×
×
  • Create New...

Important Information

Terms of Use / Privacy Policy / Guidelines / We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.