Jump to content
×
×
  • Create New...
  • 0

regen.txt weird bug


Cripplez

Question

Version of Files XXX

Hello, I tried to add the regen.txt in a new map, i added the same regen (with differenct coord) of another map with the same group vnum but when i start the server i have this syserr

SYSERR: Jul 14 19:16:26 :: SpawnMob: SpawnMob: no mob data for vnum 3031
SYSERR: Jul 14 19:16:26 :: SpawnMob: SpawnMob: no mob data for vnum 3031
SYSERR: Jul 14 19:16:26 :: SpawnMob: SpawnMob: no mob data for vnum 3031
SYSERR: Jul 14 19:16:26 :: SpawnMob: SpawnMob: no mob data for vnum 3031
SYSERR: Jul 14 19:16:26 :: SpawnMob: SpawnMob: no mob data for vnum 3031
SYSERR: Jul 14 19:16:26 :: SpawnMob: SpawnMob: no mob data for vnum 3031

I can't understand why in a map there are no problem with this group, in the other it says this, like it is trying to spawn the mob 3031 (that in fac doesn't exist) instead of spawning the group vnum

Anyone else had this problem?

 

Edited by Cripplez
Link to comment
Share on other sites

4 answers to this question

Recommended Posts

  • 1
  • Premium
34 minutes ago, Cripplez said:

 


I will explain better, it's impossible what is happening to me..
this is for example the regen.txt of the bayblack map and everything is okay, it is spawning the group 3023
fgtaEyu.png

If i try to use the same group vnum in the regen.txt of the new map, like this:

mbg4t9U.png

 

When i start the server i will have this error in the syserr:
SYSERR: Jul 14 19:16:26 :: SpawnMob: SpawnMob: no mob data for vnum 3023

 

But in the baybalck map everything is ok, in the other map there are no mob

 

If i try to use "g" instead of "r" for example with the group mob vnum 3023 i will receive the same syserr error and if i try to use "g" and the mob vnum 101 (the same group for wolves of village 1) instead of the group of mobs it will spawn only the mob 101, not the group

the stone.txt and boss.txt is working okay for metin stones and bosses, just regen.txt not

You're not giving random coordinate spaces to them, you cannot use 0 and 0 as randx and randy, min. 1 for both.

 

aipzcL3.png

Edited by Metin2 Dev
Core X - External 2 Internal

 

"Nothing's free in this life.

Ignorant people have an obligation to make up for their ignorance by paying those who help them.

Either you got the brains or cash, if you lack both you're useless."

Syreldar

Link to comment
Share on other sites

  • 0
  • Distinguished Member

Can you provide the code?

 

Otherwise it is not possible, if you copy-paste a regen.txt and only changing coords then it will work and you miss something.

Maybe stone, boss npc.txt have that 3031 and you had this syserr for a long time just only now noticing it? 

 

 

Edited by TMP4
  • Good 1
Link to comment
Share on other sites

  • 0
  • Premium

you're using the arg "m" instead of "g" in the regen, so it tries to spawn the mob instead of a group.

 

"Nothing's free in this life.

Ignorant people have an obligation to make up for their ignorance by paying those who help them.

Either you got the brains or cash, if you lack both you're useless."

Syreldar

Link to comment
Share on other sites

  • 0
53 minutes ago, TMP4 said:

Can you provide the code?

 

Otherwise it is not possible, if you copy-paste a regen.txt and only changing coords then it will work and you miss something.

Maybe stone, boss npc.txt have that 3031 and you had this syserr for a long time just only now noticing it? 

 

 

 

48 minutes ago, Syreldar said:

you're using the arg "m" instead of "g" in the regen, so it tries to spawn the mob instead of a group.


I will explain better, it's impossible what is happening to me..
this is for example the regen.txt of the bayblack map and everything is okay, it is spawning the group 3023
fgtaEyu.png

If i try to use the same group vnum in the regen.txt of the new map, like this:

mbg4t9U.png

 

When i start the server i will have this error in the syserr:
SYSERR: Jul 14 19:16:26 :: SpawnMob: SpawnMob: no mob data for vnum 3023

 

But in the baybalck map everything is ok, in the other map there are no mob

 

If i try to use "g" instead of "r" for example with the group mob vnum 3023 i will receive the same syserr error and if i try to use "g" and the mob vnum 101 (the same group for wolves of village 1) instead of the group of mobs it will spawn only the mob 101, not the group

the stone.txt and boss.txt is working okay for metin stones and bosses, just regen.txt not

 

 

 

 

**** FIXED ****

I tested more and found what cause this "bug"

 

in the regen.txt if the vnum group has  0   0   after the coordinate they will not spawn, i tried again with setting 10   10 like this
33YxfEI.png


and now everything is good

Edited by Metin2 Dev
Core X - External 2 Internal
Link to comment
Share on other sites

Guest
Unfortunately, your content contains terms that we do not allow. Please edit your content to remove the highlighted words below.
Answer this question...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Recently Browsing   0 members

    • No registered users viewing this page.


  • Metin2 Dev Github
  • Activity

    1. 6

      Owsap Productions

    2. 11

      BUG SAFEBOX disappear stacks ..

    3. 2

      Error no member named SetcCreateTime in Citem

    4. 2

      Need some help with effect slot on pickup system

    5. 1

      GF Pet system "x" level / percent

    6. 1

      disable quest esc

    7. 2

      Navicat Premium 16.1.3 x64

    8. 2

      Join the Metin2 Dev team

    9. 2

      Error no member named SetcCreateTime in Citem

Important Information

Terms of Use / Privacy Policy / Guidelines / We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.