Jump to content
  • 0
OnlyRipper

solved FreeBSD 12 & MySQL 8

Question

I've tryed to start the server using FreeBSD 12 and MySQL8 .

The problem is that the mysql client isn't compatible.

I've installed mysql8 using ports and using pks.I've tried both ways to see if there's a problem with these methods.None of them could make the connection OK.

Right now from what i've read the MySQL Client Update proccess is part of the MySQL Server.

I updated my ports,my pks,my whatever it's needed to make sure the client is compatible.

Right now they are both: mysql80-server & mysql80-client.

Someone knows or faces this problem before?

Share this post


Link to post

7 answers to this question

Recommended Posts

  • 0
vor 5 Stunden schrieb OnlyRipper:

Problem solved.Please remove the topic.Thanks!

A solution would be nice.

Share this post


Link to post
  • 0

I've reinstalled mysql80 throught ports.
Regarding the error I've encountered,in mysql8 you have to create a new user and give him the neccesary permission.

 

After connecting to your mysql with root user follow these commands:

CREATE USER 'foo'@'$' IDENTIFIED WITH mysql_native_password BY 'YourPassword';

CREATE USER 'foo'@'localhost' IDENTIFIED WITH mysql_native_password BY 'YourPassword';

GRANT ALL PRIVILEGES ON *.* TO'foo'@'localhost';

GRANT ALL PRIVILEGES ON *.* TO'foo'@'%';

FLUSH PRIVILEGES;

 

 

This allowed me to enter and indeed use the database through navicat.The problem was always the connection.I wasn't allowed to join even if it was root.
I've done what i've said upper and it worked.

I hope it will help you.Keep in mind that mysql8 uses different syntax.

(update set ..... now it's with ALTER USER etc.)

If you have any further questions feel free to ask.

Share this post


Link to post
  • 0
Posted (edited)
On 6/22/2019 at 12:39 AM, OnlyRipper said:

I've reinstalled mysql80 throught ports.
Regarding the error I've encountered,in mysql8 you have to create a new user and give him the neccesary permission.

 

After connecting to your mysql with root user follow these commands:

CREATE USER 'foo'@'$' IDENTIFIED WITH mysql_native_password BY 'YourPassword';

CREATE USER 'foo'@'localhost' IDENTIFIED WITH mysql_native_password BY 'YourPassword';

GRANT ALL PRIVILEGES ON *.* TO'foo'@'localhost';

GRANT ALL PRIVILEGES ON *.* TO'foo'@'%';

FLUSH PRIVILEGES;

 

 

This allowed me to enter and indeed use the database through navicat.The problem was always the connection.I wasn't allowed to join even if it was root.
I've done what i've said upper and it worked.

I hope it will help you.Keep in mind that mysql8 uses different syntax.

(update set ..... now it's with ALTER USER etc.)

If you have any further questions feel free to ask.

are you still available to help out ?

i have a problem, not letting me use the grant priviledges on the @'%' .. 

I cannot connect to navicat for some reason.. i don't know what to do.

i have it started on my virtual machine, but on mysql 5.6 with no problems

 

Quote

# netstat -an -f inet | grep \.3306
tcp46      0      0 *.33060                *.*                    LISTEN
tcp4       0      0 127.0.0.1.3306         *.*                    LISTEN
#
 

uQ6MfWb.png

Edited by Shahin (see edit history)

Share this post


Link to post
  • 0
On 6/22/2019 at 12:39 AM, OnlyRipper said:

I've reinstalled mysql80 throught ports.
Regarding the error I've encountered,in mysql8 you have to create a new user and give him the neccesary permission.

 

After connecting to your mysql with root user follow these commands:

CREATE USER 'foo'@'$' IDENTIFIED WITH mysql_native_password BY 'YourPassword';

CREATE USER 'foo'@'localhost' IDENTIFIED WITH mysql_native_password BY 'YourPassword';

GRANT ALL PRIVILEGES ON *.* TO'foo'@'localhost';

GRANT ALL PRIVILEGES ON *.* TO'foo'@'%';

FLUSH PRIVILEGES;

 

 

This allowed me to enter and indeed use the database through navicat.The problem was always the connection.I wasn't allowed to join even if it was root.
I've done what i've said upper and it worked.

I hope it will help you.Keep in mind that mysql8 uses different syntax.

(update set ..... now it's with ALTER USER etc.)

If you have any further questions feel free to ask.

i have same problem please help me

Share this post


Link to post
  • 0
4 minutes ago, WeedHex said:

33060

127.0.0.1.3306

 

😆

 

yes friend i did this you talking about this command sysrc mysql_args="--bind-address=127.0.0.1"

 

but not worked for me can u come with teamviewer please 

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...

Important Information

Terms of Use / Privacy Policy / Guidelines / We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.