Jump to content
×
×
  • Create New...
  • 0

New weapon set won't show up ingame :^)


Invictus

Question

Hi, I've just attempted to install a new weapon set (http://metin2dev.org/board/topic/154-new-weapons-sets-v10-v11-bombwork-studio/) for some profound reason the items aren't showing up ingame, i can get the icons to come ingame and equip it but it doesn't put the player in the right stance or show the weapon at all. I've had no other problems installing weapon sets and i did this the same way, the only difference is this contained a folder labeled "texture" which i wasn't entirely sure about so i put that in the item.epk

 

here's a list of the XML's, proto's & item list

 

BG6TMsl.png

 

ITEM LIST

75060	WEAPON	icon/item/75060.tga	d:/ymir work/item/weapon/75060.gr2
75061	WEAPON	icon/item/75060.tga	d:/ymir work/item/weapon/75060.gr2
75062	WEAPON	icon/item/75060.tga	d:/ymir work/item/weapon/75060.gr2
75063	WEAPON	icon/item/75060.tga	d:/ymir work/item/weapon/75060.gr2
75064	WEAPON	icon/item/75060.tga	d:/ymir work/item/weapon/75060.gr2
75065	WEAPON	icon/item/75060.tga	d:/ymir work/item/weapon/75060.gr2
75066	WEAPON	icon/item/75060.tga	d:/ymir work/item/weapon/75060.gr2
75067	WEAPON	icon/item/75060.tga	d:/ymir work/item/weapon/75060.gr2
75068	WEAPON	icon/item/75060.tga	d:/ymir work/item/weapon/75060.gr2
75069	WEAPON	icon/item/75060.tga	d:/ymir work/item/weapon/75060.gr2

ITEM PROTO(Client Side)

		<Item vnum="75060" hashName="µµ+0" name="Sword+0" type="1" subtype="0" weight="0" size="2" antiflag="32" flag="1" wearflag="16" immuneflag="0" gold="0" buy_price="0" limittype0="1" limitvalue0="0" limittype1="0" limitvalue1="0" applytype0="7" applyvalue0="22" applytype1="0" applyvalue1="0" applytype2="0" applyvalue2="0" value0="0" value1="15" value2="19" value3="13" value4="15" value5="0" socket0="0" socket1="0" socket2="0" socket3="0" socket4="0" socket5="0" refine_vnum="11" refine_set="1" magic_pct="15" specular="0" socket_pct="1" />
		<Item vnum="75061" hashName="µµ+1" name="Sword+1" type="1" subtype="0" weight="0" size="2" antiflag="32" flag="1" wearflag="16" immuneflag="0" gold="100" buy_price="100" limittype0="1" limitvalue0="0" limittype1="0" limitvalue1="0" applytype0="7" applyvalue0="22" applytype1="0" applyvalue1="0" applytype2="0" applyvalue2="0" value0="0" value1="15" value2="19" value3="13" value4="15" value5="7" socket0="0" socket1="0" socket2="0" socket3="0" socket4="0" socket5="0" refine_vnum="12" refine_set="2" magic_pct="15" specular="0" socket_pct="1" />
		<Item vnum="75062" hashName="µµ+2" name="Sword+2" type="1" subtype="0" weight="0" size="2" antiflag="32" flag="1" wearflag="16" immuneflag="0" gold="100" buy_price="100" limittype0="1" limitvalue0="0" limittype1="0" limitvalue1="0" applytype0="7" applyvalue0="22" applytype1="0" applyvalue1="0" applytype2="0" applyvalue2="0" value0="0" value1="15" value2="19" value3="13" value4="15" value5="14" socket0="0" socket1="0" socket2="0" socket3="0" socket4="0" socket5="0" refine_vnum="13" refine_set="3" magic_pct="15" specular="0" socket_pct="1" />
		<Item vnum="75063" hashName="µµ+3" name="Sword+3" type="1" subtype="0" weight="0" size="2" antiflag="32" flag="1" wearflag="16" immuneflag="0" gold="100" buy_price="150" limittype0="1" limitvalue0="0" limittype1="0" limitvalue1="0" applytype0="7" applyvalue0="22" applytype1="0" applyvalue1="0" applytype2="0" applyvalue2="0" value0="0" value1="15" value2="19" value3="13" value4="15" value5="21" socket0="0" socket1="0" socket2="0" socket3="0" socket4="0" socket5="0" refine_vnum="14" refine_set="4" magic_pct="15" specular="0" socket_pct="1" />
		<Item vnum="75064" hashName="µµ+4" name="Sword+4" type="1" subtype="0" weight="0" size="2" antiflag="32" flag="1" wearflag="16" immuneflag="0" gold="100" buy_price="150" limittype0="1" limitvalue0="0" limittype1="0" limitvalue1="0" applytype0="7" applyvalue0="22" applytype1="0" applyvalue1="0" applytype2="0" applyvalue2="0" value0="0" value1="15" value2="19" value3="13" value4="15" value5="28" socket0="0" socket1="0" socket2="0" socket3="0" socket4="0" socket5="0" refine_vnum="15" refine_set="5" magic_pct="15" specular="30" socket_pct="1" />
		<Item vnum="75065" hashName="µµ+5" name="Sword+5" type="1" subtype="0" weight="0" size="2" antiflag="32" flag="1" wearflag="16" immuneflag="0" gold="100" buy_price="200" limittype0="1" limitvalue0="0" limittype1="0" limitvalue1="0" applytype0="7" applyvalue0="22" applytype1="0" applyvalue1="0" applytype2="0" applyvalue2="0" value0="0" value1="15" value2="19" value3="13" value4="15" value5="35" socket0="0" socket1="0" socket2="0" socket3="0" socket4="0" socket5="0" refine_vnum="16" refine_set="6" magic_pct="15" specular="40" socket_pct="1" />
		<Item vnum="75066" hashName="µµ+6" name="Sword+6" type="1" subtype="0" weight="0" size="2" antiflag="32" flag="1" wearflag="16" immuneflag="0" gold="100" buy_price="250" limittype0="1" limitvalue0="0" limittype1="0" limitvalue1="0" applytype0="7" applyvalue0="22" applytype1="0" applyvalue1="0" applytype2="0" applyvalue2="0" value0="0" value1="15" value2="19" value3="13" value4="15" value5="42" socket0="0" socket1="0" socket2="0" socket3="0" socket4="0" socket5="0" refine_vnum="17" refine_set="7" magic_pct="15" specular="50" socket_pct="1" />
		<Item vnum="75067" hashName="µµ+7" name="Sword+7" type="1" subtype="0" weight="0" size="2" antiflag="32" flag="1" wearflag="16" immuneflag="0" gold="100" buy_price="350" limittype0="1" limitvalue0="0" limittype1="0" limitvalue1="0" applytype0="7" applyvalue0="22" applytype1="0" applyvalue1="0" applytype2="0" applyvalue2="0" value0="0" value1="15" value2="19" value3="13" value4="15" value5="49" socket0="0" socket1="0" socket2="0" socket3="0" socket4="0" socket5="0" refine_vnum="18" refine_set="8" magic_pct="15" specular="65" socket_pct="1" />
		<Item vnum="75068" hashName="µµ+8" name="Sword+8" type="1" subtype="0" weight="0" size="2" antiflag="32" flag="1" wearflag="16" immuneflag="0" gold="100" buy_price="500" limittype0="1" limitvalue0="0" limittype1="0" limitvalue1="0" applytype0="7" applyvalue0="22" applytype1="0" applyvalue1="0" applytype2="0" applyvalue2="0" value0="0" value1="15" value2="19" value3="13" value4="15" value5="56" socket0="0" socket1="0" socket2="0" socket3="0" socket4="0" socket5="0" refine_vnum="19" refine_set="9" magic_pct="15" specular="80" socket_pct="1" />
		<Item vnum="75069" hashName="µµ+9" name="Sword+9" type="1" subtype="0" weight="0" size="2" antiflag="32" flag="1" wearflag="16" immuneflag="0" gold="100" buy_price="750" limittype0="1" limitvalue0="0" limittype1="0" limitvalue1="0" applytype0="7" applyvalue0="22" applytype1="0" applyvalue1="0" applytype2="0" applyvalue2="0" value0="0" value1="15" value2="19" value3="13" value4="15" value5="63" socket0="0" socket1="0" socket2="0" socket3="0" socket4="0" socket5="0" refine_vnum="0" refine_set="0" magic_pct="15" specular="100" socket_pct="1" />

ICON XML

		<File archivedPath="icon/item/75060.tga" type="1"><![CDATA[Sourceiconitem75060.tga]]></File>

ITEM XML

		<File archivedPath="d:/ymir work/item/weapon/75060.gr2" type="1"><![CDATA[Sourceymir workitemweapon75060.gr2]]></File>
		<File archivedPath="d:/ymir work/item/weapon/set_10_bombwork.dds" type="1"><![CDATA[Sourceymir workitemweaponset_10_bombwork.dds]]></File>

If someone can help me solve this issue I'd greatly appreciate it!!

Link to comment
Share on other sites

  • Answers 10
  • Created
  • Last Reply

Top Posters For This Question

10 answers to this question

Recommended Posts

  • 0
  • Premium

The first problem i see is the query serverside, very bad query maker or very bad query-creator? :asd:

Okay, uhm make sure the compression type is < 2 and make sure you pack new things well, for testing, re-unpack it and try to open the weapon model.

 

"Nothing's free in this life.

Ignorant people have an obligation to make up for their ignorance by paying those who help them.

Either you got the brains or cash, if you lack both you're useless."

Syreldar

Link to comment
Share on other sites

  • 0

Just tested, after unpacking i can still view the model. for server side proto i just took an existing sword and altered the vnum which has worked on other sets i've added.

75060	"µµ+9"	"ITEM_WEAPON"	"WEAPON_SWORD"	2	"ANTI_MUDANG"	"ITEM_TUNABLE"	"WEAR_WEAPON"	"NONE"	100	750	0	0	15	"LEVEL"	0	"LIMIT_NONE"	0	"APPLY_ATT_SPEED"	22	"APPLY_NONE"	0	"APPLY_NONE"	0	0	15	19	13	15	63	100	1	0


An44OII.png

Link to comment
Share on other sites

  • 0
  • Premium

BG6TMsl.png

 

You mistake, the position of the war should change after putting a sword, despite of see it or not, you mistake something, and i'm pretty sure the query is the problem.

 

Better if you check the compression type.

 

"Nothing's free in this life.

Ignorant people have an obligation to make up for their ignorance by paying those who help them.

Either you got the brains or cash, if you lack both you're useless."

Syreldar

Link to comment
Share on other sites

  • 0
0412 09:24:23304 :: CreateFromMemoryFile: Cannot create texture

 the models are working fine, i just put the model value to 00010 ( level 1 sword) and it worked fine. :o i can't see any flaws in the other areas

 

 

Link to comment
Share on other sites

  • 0

Nope, it's a tab. i can get the item ingame with the correct icon, from what i can gather is it can't find the texture as it comes up with this error:

 

	
0412 09:24:23304 :: CreateFromMemoryFile: Cannot create texture

the really odd thing is it works perfectly fine if i change the number of the item file to a per-existing weapon. mmmm :angry:

 

just to make sure the tabs were right i just copied an existing item from itemlist and just modified the target file so its not the item_list mmm

Link to comment
Share on other sites

  • 0

alright, i'll try that now ^_^, wasn't aware there was any ranges on vnums :o

 

edit - thanks for the information Shogun, appears there is a range in regards to the Vnums. spent the past 3 hours redoing it multiple times to see if i made a mistake :D

Link to comment
Share on other sites

  • 0

i have same problem here i had old weapon.gr2 model with the vnum say 24509 i just replaced with my new model.gr2  but its shining i meant +9 glittering ... weapon is invisible... i even changed item_list and Icon too showing. but weapon is not showing.. any solution for it?

and for ur info i created new model by my own

Edited by birender
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


Important Information

Terms of Use / Privacy Policy / Guidelines / We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.