Jump to content
×
×
  • Create New...
  • 0

SSH: Network error: Connection refused


Invictus

Question

Hi, I'm new to configuring the SSH tunnel so that i can connect into the DB via SSH. It was all configured by a friend and working perfectly, then strangely the SSHD_config deleted itself o.O after replacing it and configuring it to the best of my knowledge to regain access to the root directory the SSH is no longer working in navicat.

http://prntscr.com/36vkz2

 

I'm not sure what information i need to provide in order to get this fixed, but any help is appreciated!

 

Edit - Fixed

Link to comment
Share on other sites

1 answer to this question

Recommended Posts

  • 0

You're probably using a different port on sshd_config.

 

To use a ssh tunnel to connect to mysql, you just need to create a local mysql user on your server and then configure navicat to use local user + ssh tunnel like this:

Hidden Content

    Give reaction to this post to see the hidden content.

Hidden Content

    Give reaction to this post to see the hidden content.

 

If you changed ssh port, you need to reload/restart ssh daemon:

 

service sshd restart
  • Love 2
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


Important Information

Terms of Use / Privacy Policy / Guidelines / We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.