Jump to content
×
×
  • Create New...
  • 0

[SOLVED]Dungeon functions not working in timer


DangIt

Question

Hey Guys,

I'm having some issues with my quests and I still can't figure out a way to solve the problem or rather, fix the issue at its core.

The dungeon quest functions don't seem to be working when executed from within a timer (character based timer), yet if I execute them through a NPC or anywhere else, it works just fine. Also, if I do "/reload q", then the dungeon functions work from within the timer again.

 

Anyone know a way around this issue?

 

Things I've already checked:

- The timer works. It gets executed and deleted as it's supposed to (syslog entries) and the quest script pieces are executed too but the functions do not get called;

- Putting a say("test") command inside the timer get's executed and works too (only if there are no dungeon functions);

- Doing a reload q solves the glitch, but messes up the whole quest (which is normal)..

 

Using a custom developed game core.

 

Edit: Solved. Close please.

Edited by DangIt
Link to comment
Share on other sites

  • Answers 0
  • Created
  • Last Reply

Top Posters For This Question

Popular Days

Top Posters For This Question

0 answers to this question

Recommended Posts

There have been no answers to this question yet

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


Important Information

Terms of Use / Privacy Policy / Guidelines / We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.