Jump to content
Forgot your email address? ×
  • Create New...
  • 0

Access denied for user 'mt2'@'localhost'



I receive this error when I try to make a metin2 server with all serverfiles.


retrying in 5 secondsmysql_real_connect: Access denied for user 'mt2'@'localhost' (using password: YES)



I'm beginner !


I want to make a metin2 server only for me :) on my pc.

If you want to help me add skype: cojocaru_dragos2010 or pm me or leave a reply with instructions.. :)


Thanks in advance !

Link to comment

3 answers to this question

Recommended Posts

  • 0
  • Moon

do this :

first open the config file on the db (or any ch) :

you will find a line like this :

PLAYER_SQL: localhost metin2 password player

open mysql one ssh :

mysql -p

write the password :


GRANT ALL PRIVILEGES ON *.* TO 'metin2'@'localhost'

change 'password' with the password you have on the config file thats all.

it should work

info :

to exit mysql on ssh use :

  • Love 2
Link to comment
  • 0

I tried with Pasha37 Windows Server Files 1.2 but I didn't find any db or any ch file that contain a line like 

PLAYER_SQL: localhost metin2 password player



and i receive the same error.


Let me note that I did not open any port/s..



EDIT: I found in D:Server_MT2SFWindowsdb and file "conf.txt" which contain these lines:

SQL_ACCOUNT = "localhost account mt2 yolo 0"
SQL_PLAYER = "localhost player mt2 yolo 0"
SQL_COMMON = "localhost common mt2 yolo 0"
SQL_HOTBACKUP = "localhost hotbackup mt2 yolo 0"

What should I do ?


Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


  • -15% Discount in Metin2 Dev Store (01/10/2021 => 31/12/2021) => Code => 15_PCT_OCT_TO_DEC_2021

Important Information

Terms of Use / Privacy Policy / Guidelines / We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.