Jump to content
Forgot your email address? ×
×
×
  • Create New...
  • 0

Archieve packed with Panama


killa673

Question

Hey Guys,

 

i have a little question.

I want to use the Panama Encryption for my Eterpacks,

 

i made a panama directory in the share folder and linked the panama folder in my auth folder.

 

the panama folder contains:

panama.lst
icon.iv

 

the panama.lst have this structure:

 

pack/icon [TAB] icon.iv

the icon.iv is 32 bytes large, and got random generated.

the icon eterpacks was packed with filetype3  and the

path to the generated iv file was given too.

 

The Auth Server can read the .iv too (i thing it)

 

syslog auth:

PANAMA: pack/icon b6914d5c0b423880fb8505e36e3f87b1e81810976e9d3f4b18e7c5208e33f117

 

 

BUT!:

 

Ingame i cant see my icons, but why?

Gamcore compiled on novaline, db core and binary compiled on mainline_released
Syserr dont show anything only the granny runtime tag with 0x8000000f...

 

Is there something more needed then the .iv? i dont think.

 

 

EDIT: My XML looks like this:

 

<ScriptFile>
<CreateEterPack ArchivePath="holyweapon" IvPath="holyweapon.iv">
<File ArchivedPath="icon/item/dagger.tga" Type="PANAMA"><![CDATA[source/icon/item/dagger.tga]]></File>
</CreateEterPack>
</ScriptFile>
 
Archiever is the newest revision from here.
Link to comment
  • Answers 4
  • Created
  • Last Reply

Top Posters For This Question

Top Posters For This Question

4 answers to this question

Recommended Posts

  • 0

 

Hey Guys,

 

i have a little question.

I want to use the Panama Encryption for my Eterpacks,

 

i made a panama directory in the share folder and linked the panama folder in my auth folder.

 

the panama folder contains:

panama.lst

icon.iv

 

the panama.lst have this structure:

 

pack/icon [TAB] icon.iv

the icon.iv is 32 bytes large, and got random generated.

the icon eterpacks was packed with filetype3  and the

path to the generated iv file was given too.

 

The Auth Server can read the .iv too (i thing it)

 

syslog auth:

PANAMA: pack/icon b6914d5c0b423880fb8505e36e3f87b1e81810976e9d3f4b18e7c5208e33f117

 

 

BUT!:

 

Ingame i cant see my icons, but why?

Gamcore compiled on novaline, db core and binary compiled on mainline_released

Syserr dont show anything only the granny runtime tag with 0x8000000f...

 

Is there something more needed then the .iv? i dont think.

 

 

EDIT: My XML looks like this:

 

<ScriptFile>
<CreateEterPack ArchivePath="holyweapon" IvPath="holyweapon.iv">
<File ArchivedPath="icon/item/dagger.tga" Type="PANAMA"><![CDATA[source/icon/item/dagger.tga]]></File>
</CreateEterPack>
</ScriptFile>
 
Archiever is the newest revision from here.

 

yes u want to help both u didnt share your solve

 

what is that?

Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Announcements

  • -15% Discount in Metin2 Dev Store (01/10/2021 => 31/12/2021) => Code => 15_PCT_OCT_TO_DEC_2021


Important Information

Terms of Use / Privacy Policy / Guidelines / We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.