Jump to content
  • 0

[Dedicated Server] Freebsd 9.2 64 bits install metin2 and apache


Elijah

Question

Hi :)

Now, FreeBSD use pkg_add command for install package.

You are solution for install Apache22   /   PHP5   / PHP5 extension AND Metin2 ?


 

If I install apache ... with sample command I have this error :

  

pkg-static: PACKAGESITE in pkg.conf is no longer supported.  Convert to the new repository style.  See pkg.conf(5)
    pkg-static: Cannot parse configuration file!
    *** [check-already-installed] Error code 70

    Stop in /usr/ports/print/indexinfo.
    *** [run-depends] Error code 1

    Stop in /usr/ports/devel/m4.
    *** [install] Error code 1

    Stop in /usr/ports/devel/m4.
    *** [build-depends] Error code 1

    Stop in /usr/ports/devel/autoconf.
    *** [build-depends] Error code 1

    Stop in /usr/ports/www/apache24.
    *** [install] Error code 1

    Stop in /usr/ports/www/apache24.
    [email protected]:/usr/ports/www/apache24 #

 


 

Now I search a  good tutorial for install : Apache22   /   PHP5   / PHP5 extension AND Metin2 ?

 

Thanks :)

 

Link to comment
Share on other sites

  • Answers 14
  • Created
  • Last Reply

Top Posters For This Question

Popular Days

14 answers to this question

Recommended Posts

  • 0

I use Freebsd 9.2 64 bits.

 

It's same with mysql :

 

 

root@ns3271:/usr/ports/databases/mysql55-server # make install
pkg-static: PACKAGESITE in pkg.conf is deprecatedPlease create a repository configuration file
===>  mysql55-server-5.5.40 pkg(8must be version 1.3.8 or greaterbut you have 1.2.7_1You must upgrade the ports-mgmt/pkg port first.
*** [
installError code 1
Stop in 
/usr/ports/databases/mysql55-server.
root@ns3271:/usr/ports/databases/mysql55-server 

 

But You are install when ?

Because now FreeBSD use only pkg_add for install package. It's new for september/october.

Link to comment
Share on other sites

  • 0

I told you I just tried it.. that means right before I replied.

 

the problem with what you're saying is that I just verified it works on this version and you're telling me it doesn't. You've yet to prove which version you're using.

 

Also, read the error.. it just says to update pkg.

 

http://metin2dev.org/board/topic/3226-how-how-upgrade-pkg/

Link to comment
Share on other sites

  • 0

Ok :)

For mysql it's work now with pkg command :)

pkg_add -rv mysql56-server

But now, I search for install Apache/php5 and PHP5-extension.

With Pkg it's ok ^^ But I need the make config :

example :

php5ext-config.png

 

 

And How are this config with pkg command ? ^^

thanks for your help :)

Edited by Metin2 Dev
Core X - External 2 Internal
Link to comment
Share on other sites

  • 0

Ok,

It's work :)

For install Mysql it's good, it's just : pkg-config mysql56-server

And metin2 work.

 

For this :

	

1. pkg update	
2. pkg upgrade (Y)	
3. go /usr/local/etc/ and Delete pkg.conf	
4. pkg_add -r portupgrade	
5. /usr/local/sbin/portupgrade -a

For install apache it's ok with :

cd /usr/ports/www/apache22
make config
make install

But after for install php5 :'( :

[email protected]:/usr/ports/www/apache22 # cd /usr/ports/www/mod_php55
[email protected]:/usr/ports/www/mod_php55 # make config

With make config it's good 

But for make install clean I have little error :

[email protected]:/usr/ports/www/mod_php55 # make install clean
===>  mod_php55-5.5.17_1 is marked as broken: : Error from bsd.apache.mk. apache22 is installed (or APACHE_PORT is defined) and port requires apache.
*** [install] Error code 1

You are solution ?

 

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


!-->
×
×
  • Create New...

Important Information

Terms of Use / Privacy Policy / Guidelines / We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.