Jump to content
×
×
  • Create New...
  • 0

Problem with player information


Vanilla

Question

Hey there,

 

I've got a critical error which leads into a trash gamefile if not solved. I don't know when exactly it happened (I reverted the last changes I made to the source code but still the error occurs).

That's why I'm asking here. It stops me from finishing vanilla 2.2 so help could be great for everyone.

 

Now to my problem:

It seems the gamecore can't read the coordinates where players are located. When I log in (after char creation or simply using an existing character) I get disconnected shortly at the beginning of the loading screen. The following syserr occurs:

 

SYSERR: Feb 28 23:09:50 :: GetValidLocation: cannot find sectree_map by map index 2
SYSERR: Feb 28 23:09:50 :: PlayerLoad: InputDB::PlayerLoad : cannot find valid location 0 x 256 (name: asdf)

 

The problem is: these are NOT the coordinates I have.

My character stands at x=469300    y=964200 map_index=1 which should clearly be the red empire. Coordinates are valid too (if I used another gamecore everything works well).

 

I also made a "prevent-this-bug" with adding an error handler which resets your x,y and map_index if you land on coordinates you shouldn't land (which would cause disconnects, you may know this). But still after resetting the coordinates the error is still there.

 

 

Additionally when I use another core, I can log in AND see that the caracter is completely messed up. Some Stats are totally weird (somewhere over 9000) and I can distribute a stat point even if I'm level 1 with no exp.

 

So I guess there's a problem with handling player information (reading and writing). Maybe someone could help me if you got the same problem once or maybe know where it'd be located (since the source is huge and I'm already looking into the connection game<->db without success)

 

 

€: Problem solved. Shouldn't edit the length.h so careless.

  • Love 1

We are the tortured.
We're not your friends.
As long as we're not visible.
We are unfixable.

Link to comment
Share on other sites

2 answers to this question

Recommended Posts

  • 0

Hey there,

 

I've got a critical error which leads into a trash gamefile if not solved. I don't know when exactly it happened (I reverted the last changes I made to the source code but still the error occurs).

That's why I'm asking here. It stops me from finishing vanilla 2.2 so help could be great for everyone.

 

Now to my problem:

It seems the gamecore can't read the coordinates where players are located. When I log in (after char creation or simply using an existing character) I get disconnected shortly at the beginning of the loading screen. The following syserr occurs:

 

The problem is: these are NOT the coordinates I have.

My character stands at x=469300    y=964200 map_index=1 which should clearly be the red empire. Coordinates are valid too (if I used another gamecore everything works well).

 

I also made a "prevent-this-bug" with adding an error handler which resets your x,y and map_index if you land on coordinates you shouldn't land (which would cause disconnects, you may know this). But still after resetting the coordinates the error is still there.

 

 

Additionally when I use another core, I can log in AND see that the caracter is completely messed up. Some Stats are totally weird (somewhere over 9000) and I can distribute a stat point even if I'm level 1 with no exp.

 

So I guess there's a problem with handling player information (reading and writing). Maybe someone could help me if you got the same problem once or maybe know where it'd be located (since the source is huge and I'm already looking into the connection game<->db without success)

 

 

€: Problem solved. Shouldn't edit the length.h so careless.

I using vanilla 2.1 I have already this problem, player information not saving when /shutdown server and cant save coordinates, some times map auto closing and game crash.. I using now YMIR's db cache and in game/maps log or syserr i dont see any coordinate error and not have any critical error. I dont know why make this, but you can check. Maybe have problem on lenght in core.

 

Note:* When i use Kingdoms #1.maps in separate core, i have error but now using all Kingdom maps in one core there no error in syserr..

Link to comment
Share on other sites

Guest
Unfortunately, your content contains terms that we do not allow. Please edit your content to remove the highlighted words below.
Answer this question...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Recently Browsing   0 members

    • No registered users viewing this page.


  • Metin2 Dev Github
  • Activity

    1. 0

      max level exp

    2. 8

      Quest States Core Crash Item Dupe Bug Fix

    3. 23

      Umbra / Soft4Win / SNap! scammer exposed!

    4. 46

      Ship Defense (Hydra Dungeon)

    5. 10

      Rodnia Glory | A REAL SPEED SERVER | Start 02.09.2022

    6. 0

      Avery seeks an experienced team manager

Important Information

Terms of Use / Privacy Policy / Guidelines / We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.