Jump to content
×
×
  • Create New...
  • 0

Access denied for user 'root'@'localhost


Meliodas

Question

i get this error when i'm trying to open channels:

 

mysql_real_connect: Access denied for user 'root'@'localhost' (using password: YES)
   failed, retrying in 5 secondsmysql_real_connect: Access denied for user 'root'@'localhost' (using password: YES)
   failed, retrying in 5 secondsmysql_real_connect: Access denied for user 'root'@'localhost' (using password: YES)
   failed, retrying in 5 secondsmysql_real_connect: Access denied for user 'root'@'localhost' (using password: YES)
   failed, retrying in 5 secondsmysql_real_connect: Access denied for user 'root'@'localhost' (using password: YES)
   failed, retrying in 5 secondsmysql_real_connect: Access denied for user 'root'@'localhost' (using password: YES)
 

Link to comment
Share on other sites

11 answers to this question

Recommended Posts

  • 0
  • Premium

Me thinking what kind of gif to use:

dumb homer simpson GIF

 

 

1 hour ago, Meliodas said:

i get this error when i'm trying to open channels:

 

mysql_real_connect: Access denied for user 'root'@'localhost' (using password: YES)
   failed, retrying in 5 secondsmysql_real_connect: Access denied for user 'root'@'localhost' (using password: YES)
   failed, retrying in 5 secondsmysql_real_connect: Access denied for user 'root'@'localhost' (using password: YES)
   failed, retrying in 5 secondsmysql_real_connect: Access denied for user 'root'@'localhost' (using password: YES)
   failed, retrying in 5 secondsmysql_real_connect: Access denied for user 'root'@'localhost' (using password: YES)
   failed, retrying in 5 secondsmysql_real_connect: Access denied for user 'root'@'localhost' (using password: YES)
 

https://stackoverflow.com/questions/20353402/access-denied-for-user-testlocalhost-using-password-yes-except-root-user

  • Metin2 Dev 3
  • Love 2
  • Good 1
Link to comment
Share on other sites

  • 0
  • Moon

Reset mysql password.

 

1./usr/local/etc/rc.d/mysql-server stop
2.mysqld_safe --skip-grant-tables &
3.mysql -u root
4.use mysql;
5.update user set password=PASSWORD("your_pass") where User='root';
6.flush privileges;
7.quit

8./usr/local/etc/rc.d/mysql-server stop
9./usr/local/etc/rc.d/mysql-server start
10.Reboot

 

Edited by Vaynz
Link to comment
Share on other sites

  • 0
12 hours ago, Vaynz said:

Reset mysql password.

 

1./usr/local/etc/rc.d/mysql-server stop
2.mysqld_safe --skip-grant-tables &
3.mysql -u root
4.use mysql;
5.update user set password=PASSWORD("your_pass") where User='root';
6.flush privileges;
7.quit

8./usr/local/etc/rc.d/mysql-server stop
9./usr/local/etc/rc.d/mysql-server start
10.Reboot

 

still not working :( 

Link to comment
Share on other sites

  • 0
  • Moon

Then try to make a new user and grant all privilegies.

But first of all try first time reboot vps and try again commands above.

Edited by Vaynz
Link to comment
Share on other sites

  • 0
  • Moon

Still not working, Dude, "And Why is it not working?"

maybe our Magical Glass-Bowl will tell us,

 

 

/usr/local/etc/rc.d/mysql-server stop

mysqld_safe --skip-grant-tables

mysql -u root

use mysql;

 

"Check all the Tables if they arent corrupted cause sometimes you cant change anything cause your tables havent got the right data / Are corrupted / Will not work properly"

 

CHECK TABLE table_name;

REPAIR TABLE table_name;

 

also use the command mysql_upgrade / mysqlcheck

In that case that you cant change the passwort you should have postet the Syserr wich is showed you after you inserted the commands above lul

  • Love 1
Link to comment
Share on other sites

  • 0
5 hours ago, ToXiC4000 said:

Still not working, Dude, "And Why is it not working?"

maybe our Magical Glass-Bowl will tell us,

 

 

/usr/local/etc/rc.d/mysql-server stop

mysqld_safe --skip-grant-tables

mysql -u root

use mysql;

 

"Check all the Tables if they arent corrupted cause sometimes you cant change anything cause your tables havent got the right data / Are corrupted / Will not work properly"

 

CHECK TABLE table_name;

REPAIR TABLE table_name;

 

also use the command mysql_upgrade / mysqlcheck

In that case that you cant change the passwort you should have postet the Syserr wich is showed you after you inserted the commands above lul

https://imgur.com/iqafnMv

https://imgur.com/undefined 

not f* working 2 days -_- 

  • Metin2 Dev 2
  • Love 1
Link to comment
Share on other sites

  • 0
11 hours ago, Mattyfikrt said:

Hi, how man? i have the same problem..

Quote

 

/usr/local/etc/rc.d/mysql-server stop

mysqld_safe --skip-grant-tables

 

mysql -u root

use mysql;

 



and AFTER

service mysql-server restart

you must change password if you using root for connect in CONFIG for Cores in ch1, ch2, ch99 etc. in (for example) .../srv1/chan

Like:

ygeUlqL.png
 

If you want connect to root via Navicat (another IP) you must:

mysql -u root -p

enter pass

GRANT ALL PRIVILEGES ON *.* TO 'root'@'%' IDENTIFIED BY '<there_wrote_your_pw>';

Edited by matyasvane
  • Metin2 Dev 1
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


Important Information

Terms of Use / Privacy Policy / Guidelines / We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.