Jump to content
  • 0
callmax

[MAP] Problem with Objects

Question

Hi,

 

I found a really nice map on the internet but the map makes a problem what i definitly don't understand and had never seen in this form.

 

This is the Map in the Worldeditor;

qsSVg.jpg

 

where the mouse cursor is , this is the ingame position in the next screen.

 

ZpV7h.jpg

 

So how could it bee that the shadows of the objects are shown, and a few of the same objects are visible but the most of them are invisible. I thought, "Yes, this must be a client error" but the syser told me absolute nothing about an object error.

 

Do maps have an "object limit" how much objects could be placed on a map?

 

cause the left side of the maps there are all objects visible but on the right side of the map i see only the shadows from the objects, and the "invisible" objects let the char stuck.

But the terrifiying thing is that the SAME objects they are invisible in the right part, are visible in other parts of the map, and that is what i definitly not understand.

 

All objects are showen in the world editor but the half map ingame is only with shadows from the "invisible" objects. I definitly don't understand this fucking bug x)

Share this post


Link to post

7 answers to this question

Recommended Posts

  • 0

#fixxed

 

3jovf.jpg

 

I never thought this could pe possible

 

take a look:

uI2de.png

 

after i deletet this folder, the map works completly, in this folder i have deleted a lot of objects, but i've never thought that:

 

The client, if he find the map in the clientfolder, the map getn'd loaded by the pack archive, they get loaded by the folder which is in the client.

 

First this is a extrem security risk and i really don't know to fixx it at the moment, imagine a hacker put the map1 blue in the client with completly removed "no-move areas", he would have a simple wallhack (i don't know if the serversideattr kick the player or block the player if he try to do that)

 

Second this is a very good thing for all mappers, so they hadn't to repack there archives to see the map ingame for developing

  • Love 1

Share this post


Link to post
  • 0

Yes there is a limit, but if the World Editor shows the objects, it must be correct. Anyway, you can check it to make it sure, it is at the beginning of the areadata if I remember well. At first I would think about some property errors, but that should be shown in the syserr, but you should check that all the property and zone files are existing in your client which are needed for this map. It is also can be a problem if your granny version is not compatible with these models, but I think, it also would cause lot of error messages.

Share this post


Link to post
  • 0

they all exists, the strange thing is a objet which is shown on a place, don't appears on a other place of the map, only his shadow.

 

Like on the screen, you see by the worldeditor all the roots, but on the ingame screen only one of them is there but the part of the map should be full with this roots

Share this post


Link to post
  • 0

Didn't have this problem with objects myself but the World Editor is quite buggy.

Share this post


Link to post
  • 0

I thought it's obvious. And this is why you have to build your client cleverly.

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...

Important Information

Terms of Use / Privacy Policy / Guidelines / We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.