Jump to content
  • We need you!

    You must register to discover all the features of our community!

  • 0

Autopatcher stop working


Question

Posted (edited)

Autopatcher without source code

Hi guys, I wanted to ask you kindly if you could help me solve this problem.

My autopatcher worked perfectly before for two days, I changed the domain namespaces to those of CloudFare, then the patcher has stopped connecting, giving me error 503.

"I could not open the configuration remotely"

 

Before the change of namespaces it worked.

 

I assume that It can no longer contact the server but I do not have enough knowledge to understand the call path that needs to be changed.

Autopatcher's files configuration:

metin2torrent.config.xml

Spoiler
<torrent_config run_path="Metin2Distribute.exe" cur_patcher_path="Metin2Distribute.exe" new_patcher_path="Metin2Distribute.exe" new_patcher_crc32="0x7c81fbec">
 
    <foreground_patch crcpatch_url="http://between2.eu/patcher/" crcversion="0.0.0.1"/>
 
</torrent_config>

 

TorrentPatch.url.xml

Spoiler
<?xml version="1.0" encoding="UTF-8" standalone="no"?>
<url localConfigPath="metin2torrent.config.xml"
    remoteConfigPath="https://between2.eu/patcher/metin2torrent.config.xml"
    languagePath="TorrentPatch.locale.xml" />

 

 

Edited by cristiandumitru (see edit history)
Link to post

7 answers to this question

Recommended Posts

  • 0
  • VIP

You can't use the patcher behind cloudflare's checking page, remove the checking page and try again.

 

Or you can have a subdomain just for the patcher that doesn't go through cloudflare or disable the checking page only on that subdomain (not sure if this is possible)

QJ0orbR.png

Logo M2IconDB

Link to post
  • 0
24 minutes ago, Karbust said:

You can't use the patcher behind cloudflare's checking page, remove the checking page and try again.

 

Or you can have a subdomain just for the patcher that doesn't go through cloudflare or disable the checking page only on that subdomain (not sure if this is possible)

So, essencialy i must remove the "Under attack" mode of cloudfare?

Link to post
  • 0
  • VIP
1 minute ago, cristiandumitru said:

So, essencialy i must remove the "Under attack" mode of cloudfare?

When I had my server I wasn't using cloudflare, but also had a page to check the browser. I had to ask my provider to remove the page just for that subdomain, even though the protection was still running. It solved my problem.

  • Love 1

QJ0orbR.png

Logo M2IconDB

Link to post
  • 0
13 hours ago, Karbust said:

When I had my server I wasn't using cloudflare, but also had a page to check the browser. I had to ask my provider to remove the page just for that subdomain, even though the protection was still running. It solved my problem.

Thank you very much for the information, the last question: How can i identify the Autopatcher? 

Link to post
  • 0
  • VIP
Posted (edited)

Follow this steps:

1 - Login to cloudflare

2 - Page rules

3 - Add page rule

4 - On url put the url to your patcher, example:  https://patcher.mywebsite.com/*

5 - At settings choose "Disable security"

6- Click save.

 

Wait about 5 minutes to make sure they are in effect and problem solved

 

 

Another advice, use a vps just for the patcher. Separe it from where your website is.

And if you decide to make your own patcher with source, you can even add a couple of those vps, having the patcher download from the one with the lowest ping automatically.

Edited by tierrilopes (see edit history)
  • Love 1
Link to post
  • 0
7 hours ago, tierrilopes said:

Follow this steps:

1 - Login to cloudflare

2 - Page rules

3 - Add page rule

4 - On url put the url to your patcher, example:  https://patcher.mywebsite.com/*

5 - At settings choose "Disable security"

6- Click save.

 

Wait about 5 minutes to make sure they are in effect and problem solved

 

 

Another advice, use a vps just for the patcher. Separe it from where your website is.

And if you decide to make your own patcher with source, you can even add a couple of those vps, having the patcher download from the one with the lowest ping automatically.

Hello, thank you very much for your help. I tried to do everything you said but it is still not working..

Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


×
×
  • Create New...

Important Information

Terms of Use / Privacy Policy / Guidelines / We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.