Jump to content

Recommended Posts

Hello all!

I cant start my mysql on my VPS and thats why i had this when i try to start server.:

Quote

PUBLIC_IP: xxxxxxxx interface vtnet0
HOSTNAME: Game2
mysql_real_connect: Can't connect to MySQL server on '127.0.0.1' (61)
cannot open direct sql connection to host: 127.0.0.1 user: metin2 db: common
cannot start server while no common sql connected
mysql_real_connect: Can't connect to MySQL server on '127.0.0.1' (61)
   failed, retrying in 5 seconds^Cmysql_real_connect: Can't connect to MySQL server on '127.0.0.1' (61)
   failed, retrying in 5 seconds

So my question is, why my mysqlt cannot start? I tried a lot of things, but its isnt work.

 

 

Link to comment
https://metin2.dev/topic/33005-mysql-not-starting-in-vps/
Share on other sites

  • Bot
4 minutes ago, Rodriguez said:

Hello all!

I cant start my mysql on my VPS and thats why i had this when i try to start server.:

So my question is, why my mysqlt cannot start? I tried a lot of things, but its isnt work.

 

 

What's the mysql version?

english_banner.gif

Link to comment
https://metin2.dev/topic/33005-mysql-not-starting-in-vps/#findComment-167078
Share on other sites

.err file is write that:

Quote

2024-09-19T20:15:21.6NZ mysqld_safe Logging to '/var/db/mysql/.err'.
2024-09-19T20:15:21.6NZ mysqld_safe Starting mysqld daemon with databases from /var/db/mysql
2024-09-19T20:15:21.706516Z 0 [Warning] [MY-010140] [Server] Could not increase number of max_open_files to more than 28521 (request: 32929)
2024-09-19T20:15:21.706525Z 0 [Warning] [MY-010142] [Server] Changed limits: table_open_cache: 14180 (requested 16384)
2024-09-19T20:15:21.992087Z 0 [System] [MY-010116] [Server] /usr/local/libexec/mysqld (mysqld 8.0.35) starting as process 10647
2024-09-19T20:15:22.038810Z 1 [System] [MY-011012] [Server] Starting upgrade of data directory.
2024-09-19T20:15:22.038827Z 1 [System] [MY-013576] [InnoDB] InnoDB initialization has started.
2024-09-19T20:15:22.782259Z 1 [ERROR] [MY-012263] [InnoDB] The Auto-extending innodb_system data file '/var/db/mysql/ibdata1' is of a different size 768 pages (rounded down to MB) than specified in the .cnf file: initial 8192 pages, max 0 (relevant if non-zero) pages!
2024-09-19T20:15:22.810115Z 1 [ERROR] [MY-012930] [InnoDB] Plugin initialization aborted with error Generic error.
2024-09-19T20:15:22.812630Z 1 [ERROR] [MY-011013] [Server] Failed to initialize DD Storage Engine.
2024-09-19T20:15:22.812736Z 0 [ERROR] [MY-010020] [Server] Data Dictionary initialization failed.
2024-09-19T20:15:22.812744Z 0 [ERROR] [MY-010119] [Server] Aborting
2024-09-19T20:15:22.814788Z 0 [System] [MY-010910] [Server] /usr/local/libexec/mysqld: Shutdown complete (mysqld 8.0.35)  Source distribution.
2024-09-19T20:15:22.6NZ mysqld_safe mysqld from pid file /var/db/mysql/.pid ended

 

Link to comment
https://metin2.dev/topic/33005-mysql-not-starting-in-vps/#findComment-167081
Share on other sites

Hello again guys!

Now i could start mysql, cuz i removed mysql80 and installed mysql57, but now i can login, but after charselect i got kicked.

root@:/usr/metin2/server # ps aux|grep mysql
mysql 1180   0.0  0.3   13600   2920  -  Is   10:19   0:00.00 /bin/sh /usr/loca
mysql 1300   0.0 45.8 1127624 464196  -  I    10:19   0:00.21 /usr/local/libexe
root  1317   0.0  0.0     436    248  0  R+   10:20   0:00.00 grep mysql
 

 

root@:/usr/metin2/server # ps aux |grep d
root    11 100.0  0.0       0     16  -  RNL  10:17   3:03.23 [idle]
root     5   0.0  0.0       0     16  -  DL   10:17   0:00.41 [rand_harvestq]
root     6   0.0  0.0       0     48  -  DL   10:17   0:00.29 [pagedaemon]
root     7   0.0  0.0       0     16  -  DL   10:17   0:00.00 [vmdaemon]
root     8   0.0  0.0       0     48  -  DL   10:17   0:00.01 [bufdaemon]
root    10   0.0  0.0       0     16  -  DL   10:17   0:00.00 [audit]
root    98   0.0  0.0   12744      4  -  IWs  -       0:00.00 adjkerntz -i
root   374   0.0  0.1   13188    856  -  Is   10:17   0:00.00 dhclient: system.
root   377   0.0  0.1   13188    952  -  Is   10:17   0:00.00 dhclient: vtnet0
_dhcp  443   0.0  0.1   13192   1064  -  ICs  10:17   0:00.00 dhclient: vtnet0
root   444   0.0  0.1   11472   1340  -  Ss   10:17   0:00.01 /sbin/devd
root   651   0.0  0.1   12900   1276  -  Ss   10:17   0:00.01 /usr/sbin/syslogd
ntpd   724   0.0  0.3   17844   2736  -  Ss   10:17   0:00.01 /usr/sbin/ntpd -p
root   747   0.0  0.2   21100   1872  -  Is   10:17   0:00.01 sshd: /usr/sbin/s
root   898   0.0  0.2   18128   2528  -  Ss   10:17   0:00.00 sendmail: accepti
smmsp  901   0.0  0.0   18128      4  -  IWs  -       0:00.00 sendmail: Queue r
root   937   0.0  0.3   21540   2948  -  Ss   10:17   0:00.02 sshd: root@pts/0
root  1117   0.0  1.8   43568  17988  0  S    10:18   0:00.20 ./db
 

Any idea?

 

Link to comment
https://metin2.dev/topic/33005-mysql-not-starting-in-vps/#findComment-167083
Share on other sites

Don't use any images from : imgur, turkmmop, freakgamers, inforge, hizliresim... Or your content will be deleted without notice...
Use : https://metin2.download/media/add/

Please use https://metin2.download/ when uploading files smaller than 100MB, otherwise the approval will take longer due to manual upload.

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now
×
×
  • Create New...

Important Information

Terms of Use / Privacy Policy / Guidelines / We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.