Jump to content
  • Join-Us

    https://metin2.dev is the 1st international community on Metin2 development. Join us to develop your skills and share your knowledge with the community, respectful and ethical forum.

  • 0

My root server's authentication is not connecting


Petrezselyem

Question

Hi. I set up my client to my pc, i started a root server. I'm done with configurations, and my server sends this message:

"start of pid: 1577 

socket_connect: HOST: (My public ipv4 address):15000, could not connect"

And my PutTY sais: Master Auth26 connection: Operation timed out.

What should I do with it? 

P.s.: I opened all of the ports of channel 1, FTP, and db as well.

Link to comment
Share on other sites

  • Answers 7
  • Created
  • Last Reply

Top Posters For This Question

Popular Days

Top Posters For This Question

7 answers to this question

Recommended Posts

  • 0
  • Distinguished Member
2 hours ago, Petrezselyem said:

Hi. I set up my client to my pc, i started a root server. I'm done with configurations, and my server sends this message:

"start of pid: 1577 

socket_connect: HOST: (My public ipv4 address):15000, could not connect"

And my PutTY sais: Master Auth26 connection: Operation timed out.

What should I do with it? 

P.s.: I opened all of the ports of channel 1, FTP, and db as well.

Did I talk you yesterday in youtube comments? I was checking this morning but didn't find your comment.

Anyway better here, so

Quote

"socket_connect: HOST: (My public ipv4 address😞15000, could not connect"

That is your error. You public IP address should not appear there because port 15000 is the db what you should access via localhost (127.0.0.1)

If you edited the 127.0.0.1s to your ip (lots of people do it actually because they don't know 127.0.0.1 == localhost), then revert the changes. You only need to set

BIND_IP: private_ip
PROXY_IP: public_ip

In your CONFIG files. Do not edit other stuffs and don't forget to remove those from comment (#BIND_IP... -> BIND_IP... so you remove the #)

TL:DR: Do not edit 127.0.0.1 because that is not az external ip or something, that is localhost. 

Link to comment
Share on other sites

  • 0
46 minutes ago, TMP4 said:

Did I talk you yesterday in youtube comments? I was checking this morning but didn't find your comment.

Anyway better here, so

That is your error. You public IP address should not appear there because port 15000 is the db what you should access via localhost (127.0.0.1)

If you edited the 127.0.0.1s to your ip (lots of people do it actually because they don't know 127.0.0.1 == localhost), then revert the changes. You only need to set

BIND_IP: private_ip
PROXY_IP: public_ip

In your CONFIG files. Do not edit other stuffs and don't forget to remove those from comment (#BIND_IP... -> BIND_IP... so you remove the #)

TL:DR: Do not edit 127.0.0.1 because that is not az external ip or something, that is localhost. 

Igen, te voltál akivel beszéltem. Viszont, ha 127.0.0.1-re teszem rá, spanok se, de főleg én se tudok felmenni, és ugyanúgy nem csatlakozik. Viszont a PROXY_IP-s dolognál addig nem engedett tovább a karakter választásnál, ameddig nem írtam oda elé, hogy ENABLE_PROXY_IP

Link to comment
Share on other sites

  • 0
  • Distinguished Member
21 minutes ago, Petrezselyem said:

Igen, te voltál akivel beszéltem. Viszont, ha 127.0.0.1-re teszem rá, spanok se, de főleg én se tudok felmenni, és ugyanúgy nem csatlakozik. Viszont a PROXY_IP-s dolognál addig nem engedett tovább a karakter választásnál, ameddig nem írtam oda elé, hogy ENABLE_PROXY_IP

So here we can't talk hungarian. Keep english.

You're really mixing things. ENABLE_PROXY_IP is only needed in the source (common/service.h), and it is there, it is enabled. You don't need to do anything with ENABLE_PROXY_IP.

When you edited the PROXY_IP: ip to ENABLE_PROXY_IP: ip in your CONFIG files you actually just removed PROXY_IP because ENABLE_PROXY_IP is not a token, it will not read it. Put the PROXY_IP back to your CONFIG files and revert the changes what you did with 127.0.0.1. As I said that is localhost, that is okey.

If you could not connect with PROXY_IP: ip in your CONFIG files then your ports are not opened.
Provide a screenshot of your ports, how did you opened them.

Here's an example of mine:

091818Screenshot-1.png

Edited by TMP4
Link to comment
Share on other sites

  • 0
53 minutes ago, TMP4 said:

So here we can't talk hungarian. Keep english.

You're really mixing things. ENABLE_PROXY_IP is only needed in the source (common/service.h), and it is there, it is enabled. You don't need to do anything with ENABLE_PROXY_IP.

When you edited the PROXY_IP: ip to ENABLE_PROXY_IP: ip in your CONFIG files you actually just removed PROXY_IP because ENABLE_PROXY_IP is not a token, it will not read it. Put the PROXY_IP back to your CONFIG files and revert the changes what you did with 127.0.0.1. As I said that is localhost, that is okey.

If you could not connect with PROXY_IP: ip in your CONFIG files then your ports are not opened.
Provide a screenshot of your ports, how did you opened them.

Here's an example of mine:

091818Screenshot-1.png

I checked, and fixed everything what you had told me, but exactly nothing changed. 
The client now lets me in, but whenever I choose my character it sends me back to the login window. 

When I type "start" to vBox, it sais with uppercase, when trying to acces auth: Connection refused.

 

also db syserr: 

SYSERR: Dec  9 17:12:03 :: hupsig: SIGHUP, SIGINT, SIGTERM signal has been received. shutting down.
SYSERR: Dec  9 17:12:03 :: pid_deinit: 
End of pid

SYSERR: Dec  9 17:12:07 :: pid_init: 
Start of pid: 1082

SYSERR: Dec  9 17:12:07 :: Start: TABLE_POSTFIX not configured use default
 

Edited by Petrezselyem
Link to comment
Share on other sites

  • 0
  • Distinguished Member

If nothing changed then you didn't fix your edits regarding the 127.0.0.1 since it can't still says
"socket_connect: HOST: (My public ipv4 address):15000, could not connect""

Since you just edited back to 127.0.0.1

I suggest to re-extract the serverfile and change nothing but

BIND_IP: your_private_ip
PROXY_IP: your_public_ip

in the CONFIGs. (Again: don't forget to remove the #)

Edited by TMP4
Link to comment
Share on other sites

  • 0
13 minutes ago, TMP4 said:

If nothing changed then you didn't fix your edits regarding the 127.0.0.1 since it can't still says
"socket_connect: HOST: (My public ipv4 address):15000, could not connect""

Since you just edited back to 127.0.0.1

I suggest to re-extract the serverfile and change nothing but

BIND_IP: your_private_ip
PROXY_IP: your_public_ip

in the CONFIGs. (Again: don't forget to remove the #)

I re-extrated it, and it's also saying connection refused...

 

4 minutes ago, Petrezselyem said:

I re-extrated it, and it's also saying connection refused...

 

SYSERR: Dec  9 17:25:12 :: pid_init: 
Start of pid: 1187

SYSERR: Dec  9 17:25:12 :: Start: TABLE_POSTFIX not configured use default
 

 

Does that mean anything to me?

Link to comment
Share on other sites

  • 0
  • Distinguished Member
10 minutes ago, Petrezselyem said:

I re-extrated it, and it's also saying connection refused...

 

SYSERR: Dec  9 17:25:12 :: pid_init: 
Start of pid: 1187

SYSERR: Dec  9 17:25:12 :: Start: TABLE_POSTFIX not configured use default
 

 

Does that mean anything to me?

Those are normal. Hit me in DM with a Teamviewer or Anydesk because I can't help just with texting. (In the next 1 hour)

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


×
×
  • Create New...

Important Information

Terms of Use / Privacy Policy / Guidelines / We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.