Jump to content
For maintenance and updates, the community will be offline on 31 December 2022 ×
  • 0

How to disable mob's aggressivity on a certain map?


SilkTouchX

Question

Hello, I want to disable mob's aggressivity on a map.

What I tried: char_manager.cpp SpawnMobRange function:
if (bAgressive) --> if (bAgressive && lMapIndex != 155)

It's not working, they're still agressive.

How to do it properly?

Edited by SilkTouchX
Link to comment
Share on other sites

  • Answers 1
  • Created
  • Last Reply

Top Posters For This Question

Popular Days

Top Posters For This Question

1 answer to this question

Recommended Posts

  • 0
  • Distinguished Member

Try this:

char_state.cpp
void CHARACTER::SetNotAggressive()
{
	REMOVE_BIT(m_pointsInstant.dwAIFlag, AIFLAG_AGGRESSIVE);
}

char.h:
void				SetNotAggressive();

Then in char_manager: CHARACTER_MANAGER::SpawnMob look for ch->SetProto(pkMob); and add

if (lMapIndex == 155) // or check for it's dungeon mapindex...
	ch->SetNotAggressive();

Untested but should work..

Edited by TMP4
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


  • Activity

    1. 992

      [40250] Reference Serverfile + Client + Src [15 Available Languages]

    2. 3

      Biologist Manager (C++ & LUA)

    3. 3

      Visual studio 2022 compiling issue

    4. 63

      Metin2 | Mount System Renewal

    5. 58

      Metin2 2004 Beta Client

    6. 0

      🔥Paradise2 PVP SERVER GLOBAL!! EN-ES-PT 🕐📢Apertura 11 de diciembre 21 horas de España!

    7. 0

      Please help here ( Sush system problem )

  • Recently Browsing

    • No registered users viewing this page.
×
×
  • Create New...

Important Information

Terms of Use / Privacy Policy / Guidelines / We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.