Jump to content
For maintenance and updates, the community will be offline on 31 December 2022 ×
  • 0

[HELP] (compile error) /usr/local/bin/ld: cannot find -lsql


Ulthar

Question

  • Premium

Hello!

I just came back from work and depression, and i want to continue my server development.
I wanted to compile my server to see, its working or not.
First time, i did, and it worked, nothing wrong with it.
Two days later, i wanted to compile again, and it not worked. (did nothing in this 2 days with my server, only playing with other game.(only changed 2 item-description))

pic: https://metin2.download/picture/8PIlJvh1OopBI9Oz0eOV1A3TW7FAF0UR/.png
Info about freebsd: 9.2-RELEASE i386



I dont know what is this error, cuz i dont have this location:  /usr/local/bin/ld   (maybe this is the problem, i really dont know, i never met with this type of errors)

Appreciate if you can help me.

Edited by Metin2 Dev
Core X - External 2 Internal
  • Metin2 Dev 1
Link to comment
Share on other sites

3 answers to this question

Recommended Posts

  • 0
  • Premium
59 minutes ago, cncn said:

Compile libsql again. Check the makefile for libdir.

Already restarted everything with clear files, and slowly reuploaded my files into it. Working (i didnt tried your answer, but thanks!)

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


  • Activity

    1. 0

      Need Help With Char_Item.cpp

    2. 0

      ULTERIUS2.COM

    3. 7

      Killua - Unholy God Set

    4. 2

      Visual studio 2022 compiling issue

    5. 991

      [40250] Reference Serverfile + Client + Src [15 Available Languages]

  • Recently Browsing

    • No registered users viewing this page.
×
×
  • Create New...

Important Information

Terms of Use / Privacy Policy / Guidelines / We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.