Jump to content
×
×
  • Create New...
  • 0

Getting kicked after selecting character.


basforos

Question

Greetings everyone, 
I recently setup a server with hamachi and for testing proposes I want my friend to login and test stuff with me. He can log into his account but after he selects his character, he gets kicked out to the login screen. 

 

Here's what I tried:

without any success. Can someone help me?

 

Kind Regards

Link to comment
Share on other sites

  • Answers 5
  • Created
  • Last Reply

Top Posters For This Question

Top Posters For This Question

5 answers to this question

Recommended Posts

  • 0

Update: I followed the first guide again. Now my friend can join the server without hamachi but just using my external IP in root. Although an other issue appear, now I get kicked after selecting a character? can someone help me?

 

Spoiler

Feb 20 00:52:28 :: InputDB::login_success: admin
Feb 20 00:52:28 :: SYSTEM: new connection from [192.168.2.6] fd: 22 handshake 514896596 output input_len 0, ptr 0x307c5c00
Feb 20 00:52:29 :: MARK_SERVER: Login
Feb 20 00:52:29 :: LargePacket Size 128
Feb 20 00:52:29 :: MARK_SERVER: GuildMarkIDXList 135 bytes sent.
Feb 20 00:52:29 :: MARK_SERVER: Sending blocks. (imgIdx 0 diff 0 size 10)
Feb 20 00:52:29 :: SYSTEM: closing socket. DESC #22

Feb 20 00:52:33 :: SYSTEM: closing socket. DESC #21
Feb 20 00:52:37 :: SYSTEM: new connection from [192.168.2.6] fd: 21 handshake 2051132522 output input_len 0, ptr 0x307c5800
Feb 20 00:52:37 :: SYSTEM: closing socket. DESC #21
Feb 20 00:52:39 :: GLOBAL_TIME: Feb 20 00:52:39 time_gap 0

 

Link to comment
Share on other sites

  • 0

You can try to connect with your home network ip.. You dont need public ip if you are in same network.. And your friend just with public ip.. I have too server on public ip.. But idk where is problem... For me all works fine.

For example.. Here is my settings..

My Public IP from provider: 157.156.57.104 (only example)
My PC IP from router 192.168.0.15
My virtualbox IP from router 192.168.0.16

You must set in source public IP from provider in this example: 157.156.57.104

Now in serverinfo.py too  public ip (157.156.57.104 //for your friends and you) - (if you want stay in your network //only for you - 192.168.0.16)

And after this all you must go in router settings and set port forwarding.. How?

You must open your ports needed for game.. (ch1, ch99, auth)

For example: CH1 13010, CH99 13099, AUTH 11000 and THIS PORTS MUST BE OPENED WITH YOUR IP FROM VIRTUALBOX in example this: 192.168.0.16
 

Link to comment
Share on other sites

  • 0
11 hours ago, Cunoo said:

You can try to connect with your home network ip.. You dont need public ip if you are in same network.. And your friend just with public ip.. I have too server on public ip.. But idk where is problem... For me all works fine.

For example.. Here is my settings..

My Public IP from provider: 157.156.57.104 (only example)
My PC IP from router 192.168.0.15
My virtualbox IP from router 192.168.0.16

You must set in source public IP from provider in this example: 157.156.57.104

Now in serverinfo.py too  public ip (157.156.57.104 //for your friends and you) - (if you want stay in your network //only for you - 192.168.0.16)

And after this all you must go in router settings and set port forwarding.. How?

You must open your ports needed for game.. (ch1, ch99, auth)

For example: CH1 13010, CH99 13099, AUTH 11000 and THIS PORTS MUST BE OPENED WITH YOUR IP FROM VIRTUALBOX in example this: 192.168.0.16
 

I did set my external IP in the source, before I did that I could connect without getting disconnected but my friend couldn't. Also, if I use my external IP on root (serverinfo.py) I can't even log in, thus I use the virtual machine local IP with which I can log in but get kicked after selecting a character. I also did forward my ports from my router website.

It also spams me with:

bf8f56162187af3a0dc33ef36c2161d8.png

 

after I changed desc_client.cpp to external ip

Edited by basforos
Link to comment
Share on other sites

  • 0

This spam is normal.. Because you have set public ip instadead.. You can comment this syserr log in src.. This is not problem.. Your friend can login if you have set your public ip in src and client? Only you are kicked? Interesting problem.. You are too kicked if you use internal ip? Just you can use internal ip if you are in same network.. (in client)  and your friend just public ip.. Source is okey... You can send me PM I can try help you..

Edit: btw. do you have fixed start core with 192.168? + 10.xxx? 

Edited by Cunoo
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


Important Information

Terms of Use / Privacy Policy / Guidelines / We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.