Jump to content
×
×
  • Create New...
  • 0

EterManager


AllahPsico

Question

Good morning,

Yesterday I formatted my PC I encountered a problem with the EterManager decompiler, when I try to extract the files I close the program and always give me the same problem:

System.DllNotFoundException: Unable to load LzoModule.dll DLL: Can not find the specified module. (Exception by HRESULT: 0x8007007E).
In EterManager.Utilities.LzoHelper.Decompress (IntPtr source, Int32 compressedSize, Int32 decompressedSize, IntPtr decompressoFilePointer)
In EterManager.Utilities.LzoHelper.DecompressData (Int32 decompressedSize, Int32 compressedSize, Byte [] compressedData)
In EterManager.DataAccessLayer.EterFilesDal.NormalizeIndexFile (String filePath, Byte [] indexKey)
In EterManager.DataAccessLayer.EterFilesDal.ReadIndexFile (String filePath, Byte [] indexKey, String parentFile)
In EterManager.DataAccessLayer.EterFilesDal.UnpackFile (FileInfo packFile, String saveFilesPath, Byte [] indexKey, Byte [] packKey, Action2, progressCallback, action2 fileLoggingCallback)
In EterManager.UserInterface.ViewModels.WorkingItemVm. <UnpackFileAction> b__22_0 ()
In System.Threading.Tasks.Task.InnerInvoke ()
In System.Threading.Tasks.Task.Execute ()
--- Stack the stack from the previous position where the exception was generated ---
In System.Runtime.CompilerServices.TaskAwaiter.ThrowForNonSuccess (task task)
In System.Runtime.CompilerServices.TaskAwaiter.HandleNonSuccessAndDebuggerNotification (task task)
In EterManager.UserInterface.ViewModels.WorkingItemVm. <UnpackFileAction> d__22.MoveNext ()
--- Stack the stack from the previous position where the exception was generated ---
In System.Runtime.CompilerServices.AsyncMethodBuilderCore. <> C. <ThrowAsync> b__6_0 (Object State)
In System.Windows.Threading.ExceptionWrapper.InternalRealCall (Delegate Callback, Object Arguments, IntAr32)
In System.Windows.Threading.ExceptionWrapper.TryCatchWhen (object source, delegate recall, object arguments, numArgs Int32, delegate catchHandler)

I claim that I tried to modify all LzoModule.dll Downloading various releases released! Unfortunately, 
the problem persists with the versions, how do I fix it?

I tried downloading those versions :

Changelog (1.0.1.140 - 02/03/2015)
Changelog (1.0.1.146 - 07/04/2015)
Changelog (1.0.2.198 - 03/06/2015)
Changelog (1.0.2.241 - 15/02/2016)
Changelog (1.1.2.654 - 28/06/2016)
Changelog (1.1.3.660 - 28/06/2016)
Changelog 1.1.4.768 - 02/07/2016

 

Link to comment
Share on other sites

4 answers to this question

Recommended Posts

  • 0
7 hours ago, Fleon said:

Thanks :)

6 hours ago, Johnny69 said:

You change windows configuration from 32bits to 64bits and that dll not work on 64bits.

Here you have a version which work on 64 bits:

This is the hidden content, please

you are the best my friend ,thanks so much for my heart!

I can close the discussion,thanks.

Best Regards

 

 

  • Metin2 Dev 2
  • Love 1
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    • No registered users viewing this page.


Important Information

Terms of Use / Privacy Policy / Guidelines / We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.