Jump to content
×
×
  • Create New...
  • 0

FreeBSD 10.3 Networking Configuration


Summex

Question

Hello guys !

I am correctly trying to setup a server for me with a clean VM. I installed freebsd 10.3, mysql 5.6 and so on. I want to run a server purely for me no other people should be able to connect. I have set the network adapter in virtualbox to bridge mode. Now I have to setup the networking in configuraiton in freebsd the problem is, i dont know how. The interface has changed and now I dont know how to setup the networking in freebsd to allow the server to run for just me.

This is how it looks when i go into network configuration:

i.epvpimg.com//cPdCg.png

I would appreciate it if someone could tell me where to put my ip adress and since i am doing it without hamachi with ot wihtout 100 at the end ? what to put in at the other options etc.

If someone could help that would be really great, I am looking forward to any answers ! :)

Link to comment

11 answers to this question

Recommended Posts

  • 0

I changed the adapter to nat, activated dhcp. When I run dhclient em0 it tells me the service is already running. When i enable dhcp it automatically sets an ip and the netmask, when i change any of the values it disables it again. Using the automatically set ip by dhcp wont allow me to connect to the server via filezilla. Any ideas ?

Link to comment
  • 0
  • Premium
1 hour ago, Summex said:

I changed the adapter to nat, activated dhcp. When I run dhclient em0 it tells me the service is already running. When i enable dhcp it automatically sets an ip and the netmask, when i change any of the values it disables it again. Using the automatically set ip by dhcp wont allow me to connect to the server via filezilla. Any ideas ?

It allows you do to so, im using it.

Make sure you edited sshd config to permit root login and enabling port 22.

Like i said, vmware will allow you to have dhcp on without changing ip on every session. It wont happen because the ip assigned it out of reach for the other pcs on your home (if you have for example 192.168.1.2 >> 192.168.1.25   it will assign you in the 192.168.200.x fr example).

  • Love 1
Link to comment
  • 0
14 minutes ago, Crystal™ said:

Do you want set up the network for hamachi?

No I want to be the only one able to connect to the server

5 minutes ago, tierrilopes said:

It allows you do to so, im using it.

Make sure you edited sshd config to permit root login and enabling port 22.

Like i said, vmware will allow you to have dhcp on without changing ip on every session. It wont happen because the ip assigned it out of reach for the other pcs on your home (if you have for example 192.168.1.2 >> 192.168.1.25   it will assign you in the 192.168.200.x fr example).

How can I save the changes I make to the sshd_config via ee /etc/ssh/sshd_config ? dumb question i know but i cant find the option / command prompt / whatever to save and exit. Are there any other places that I have to enable port 22 ? And the ip adress dhcp is giving me is different compared to a 192.168.xx.xx one.

Link to comment
  • 0
  • Premium
5 minutes ago, Summex said:

No I want to be the only one able to connect to the server

How can I save the changes I make to the sshd_config via ee /etc/ssh/sshd_config ? dumb question i know but i cant find the option / command prompt / whatever to save and exit. Are there any other places that I have to enable port 22 ? And the ip adress dhcp is giving me is different compared to a 192.168.xx.xx one.

 

use ee.

 

Do this:

ee /etc/ssh/sshd_config

Look for:

#PermitRootLogin no

Change into:

PermitRootLogin yes

 

Look for:

#Port 22

Change into:

Port 22

 

To save and exit editor, press:

ESC-->Enter-->Enter

 

Then restart sshd with:

service sshd restart

  • Love 1
Link to comment
  • 0
  • Premium
7 minutes ago, Summex said:

No I want to be the only one able to connect to the server

How can I save the changes I make to the sshd_config via ee /etc/ssh/sshd_config ? dumb question i know but i cant find the option / command prompt / whatever to save and exit. Are there any other places that I have to enable port 22 ? And the ip adress dhcp is giving me is different compared to a 192.168.xx.xx one.

 

Link to comment
  • 0
8 minutes ago, tierrilopes said:

 

use ee.

 

Do this:

ee /etc/ssh/sshd_config

Look for:

#PermitRootLogin no

Change into:

PermitRootLogin yes

 

Look for:

#Port 22

Change into:

Port 22

 

To save and exit editor, press:

ESC-->Enter-->Enter

 

Then restart sshd with:

service sshd restart

Thanks, I got that working. Still the problem remains that the Network Configuration isn't quite right. I think the ip adress dhcp automatically sets is wrong, is that a possibility and could that be the cause of the problems ? I assume it has something to do with the default router / gateway that is set in the options. when i use a website that tells me my ip is that of any use ? cause ifconfig gives me the "wrong" ip adress that is set in the default router in networking configuration.

Link to comment
  • 0
  • Premium
1 minute ago, Summex said:

Thanks, I got that working. Still the problem remains that the Network Configuration isn't quite right. I think the ip adress dhcp automatically sets is wrong, is that a possibility and could that be the cause of the problems ? I assume it has something to do with the default router / gateway that is set in the options. when i use a website that tells me my ip is that of any use ? cause ifconfig gives me the "wrong" ip adress that is set in the default router in networking configuration.

If you want it only for yourself, you dont need to touch your router.

PM me with your teamviewer.

  • Love 1
Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Announcements

  • -15% Discount in Metin2 Dev Store (01/10/2021 => 31/12/2021) => Code => 15_PCT_OCT_TO_DEC_2021


Important Information

Terms of Use / Privacy Policy / Guidelines / We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.