Jump to content

edem0202

Member
  • Posts

    8
  • Joined

  • Last visited

  • Feedback

    0%

About edem0202

Informations

  • Gender
    Male
  • Country
    Hungary
  • Nationality
    Hungarian

edem0202's Achievements

Apprentice

Apprentice (3/16)

  • Dedicated
  • First Post
  • One Month Later
  • One Year In
  • Week One Done

Recent Badges

1

Reputation

  1. I solved it in the meantime.
  2. Hello. I have a previously used server file that has a database. But for some reason the mysql server doesn't want to start... Can someone help me with this? Thank you in advance. .err: 241223 18:20:56 mysqld_safe Logging to '/var/db/mysql/.err'. 241223 18:20:56 mysqld_safe Starting mysqld daemon with databases from /var/db/mysql 2024-12-23 18:20:56 0 [Warning] TIMESTAMP with implicit DEFAULT value is deprecated. Please use --explicit_defaults_for_timestamp server option (see documentation for more details). 2024-12-23 18:20:56 0 [Note] /usr/local/libexec/mysqld (mysqld 5.6.51) starting as process 3536 ... 2024-12-23 18:20:56 3536 [Note] Plugin 'FEDERATED' is disabled. 2024-12-23 18:20:56 3536 [Note] InnoDB: Using atomics to ref count buffer pool pages 2024-12-23 18:20:56 3536 [Note] InnoDB: The InnoDB memory heap is disabled 2024-12-23 18:20:56 3536 [Note] InnoDB: Mutexes and rw_locks use GCC atomic builtins 2024-12-23 18:20:56 3536 [Note] InnoDB: Memory barrier is not used 2024-12-23 18:20:56 3536 [Note] InnoDB: Compressed tables use zlib 1.2.12 2024-12-23 18:20:56 3536 [Note] InnoDB: Not using CPU crc32 instructions 2024-12-23 18:20:56 3536 [Note] InnoDB: Initializing buffer pool, size = 128.0M 2024-12-23 18:20:56 3536 [Note] InnoDB: Completed initialization of buffer pool 2024-12-23 18:20:56 3536 [Note] InnoDB: Highest supported file format is Barracuda. 2024-12-23 18:20:56 3536 [Note] InnoDB: The log sequence numbers 1600607 and 1600607 in ibdata files do not match the log sequence number 1600617 in the ib_logfiles! 2024-12-23 18:20:56 3536 [Note] InnoDB: Database was not shutdown normally! 2024-12-23 18:20:56 3536 [Note] InnoDB: Starting crash recovery. 2024-12-23 18:20:56 3536 [Note] InnoDB: Reading tablespace information from the .ibd files... 2024-12-23 18:20:56 20e6c000 InnoDB: Operating system error number 13 in a file operation. InnoDB: The error means mysqld does not have the access rights to InnoDB: the directory. InnoDB: Error: could not open single-table tablespace file ./common/innodb_index_stats.ibd InnoDB: We do not continue the crash recovery, because the table may become InnoDB: corrupt if we cannot apply the log records in the InnoDB log to it. InnoDB: To fix the problem and start mysqld: InnoDB: 1) If there is a permission problem in the file and mysqld cannot InnoDB: open the file, you should modify the permissions. InnoDB: 2) If the table is not needed, or you can restore it from a backup, InnoDB: then you can remove the .ibd file, and InnoDB will do a normal InnoDB: crash recovery and ignore that table. InnoDB: 3) If the file system or the disk is broken, and you cannot remove InnoDB: the .ibd file, you can set innodb_force_recovery > 0 in my.cnf InnoDB: and force InnoDB to continue crash recovery here. 241223 18:20:56 mysqld_safe mysqld from pid file /var/db/mysql/.pid ended
  3. It's ok, thank you very much for your help. ?
  4. FreeBSD 13.1 amd64
  5. root@:~ # portsnap fetch update Looking up portsnap.FreeBSD.org mirrors... 5 mirrors found. Fetching snapshot tag from dualstack.aws.portsnap.freebsd.org... done. Fetching snapshot metadata... done. Updating from Fri Dec 1 12:16:39 CET 2023 to Fri Dec 1 13:28:09 CET 2023. Fetching 5 metadata patches... done. Applying metadata patches... done. Fetching 0 metadata files... done. Fetching 2 patches. (2/2) 100.00% done. done. Applying patches... done. Fetching 0 new ports or files... done. Removing old files and directories... done. Extracting new files: /usr/ports/editors/linux-sublime-text4/ /usr/ports/emulators/duckstation/ Building new INDEX files... done. root@:~ # cd /usr/ports/graphics/devil root@:/usr/ports/graphics/devil # make deinstall clean ===> Deinstalling for devil ===> Deinstalling devil-1.8.0_4,1 Checking integrity... done (0 conflicting) Deinstallation has been requested for the following 1 packages (of 0 packages in the universe): Installed packages to be REMOVED: devil: 1.8.0_4,1 Number of packages to be removed: 1 The operation will free 3 MiB. [1/1] Deinstalling devil-1.8.0_4,1... [1/1] Deleting files for devil-1.8.0_4,1: 100% ===> Cleaning for devil-1.8.0_4,1 root@:/usr/ports/graphics/devil # make install clean ===> Building/installing portconfig as it is required for the config dialog ===> Cleaning for portconfig-0.6.1 /!\ ERROR: /!\ Ports Collection support for your FreeBSD version has ended, and no ports are guaranteed to build on this system. Please upgrade to a supported release. No support will be provided if you silence this message by defining ALLOW_UNSUPPORTED_SYSTEM. *** Error code 1 Stop. make[3]: stopped in /usr/ports/ports-mgmt/portconfig *** Error code 1 Stop. make[2]: stopped in /usr/ports/ports-mgmt/portconfig ===> Options unchanged /!\ ERROR: /!\ Ports Collection support for your FreeBSD version has ended, and no ports are guaranteed to build on this system. Please upgrade to a supported release. No support will be provided if you silence this message by defining ALLOW_UNSUPPORTED_SYSTEM. *** Error code 1 Stop. make[1]: stopped in /usr/ports/graphics/devil *** Error code 1 Stop. make: stopped in /usr/ports/graphics/devil root@:/usr/ports/graphics/devil #
  6. root@:~ # pkg install devil Updating FreeBSD repository catalogue... FreeBSD repository is up to date. All repositories are up to date. Checking integrity... done (0 conflicting) The most recent versions of packages are already installed root@:~ # cd /usr/ports/graphics/devil root@:/usr/ports/graphics/devil # make install clean ===> Building/installing portconfig as it is required for the config dialog ===> Cleaning for portconfig-0.6.1 /!\ ERROR: /!\ Ports Collection support for your FreeBSD version has ended, and no ports are guaranteed to build on this system. Please upgrade to a supported release. No support will be provided if you silence this message by defining ALLOW_UNSUPPORTED_SYSTEM. *** Error code 1 Stop. make[3]: stopped in /usr/ports/ports-mgmt/portconfig *** Error code 1 Stop. make[2]: stopped in /usr/ports/ports-mgmt/portconfig ===> Options unchanged /!\ ERROR: /!\ Ports Collection support for your FreeBSD version has ended, and no ports are guaranteed to build on this system. Please upgrade to a supported release. No support will be provided if you silence this message by defining ALLOW_UNSUPPORTED_SYSTEM. *** Error code 1 Stop. make[1]: stopped in /usr/ports/graphics/devil *** Error code 1 Stop. make: stopped in /usr/ports/graphics/devil root@:/usr/ports/graphics/devil #
  7. Hello. Could you help me with this? ld-elf32.so.1: Shared object "libIL.so.1" not found, required by "game" Devil installed. Thanks in advance.?
  8. Have a nice day! What could be the problem with translating the game? Sorry for the bad English. linking ../game.... ld: error: unable to find library -lIL ld: error: unable to find library -lpng ld: error: unable to find library -ltiff ld: error: unable to find library -lmng ld: error: unable to find library -llcms ld: error: unable to find library -ljpeg clang-15: error: linker command failed with exit code 1 (use -v to see invocation) gmake: *** [Makefile:127: ../game] Error 1
×
×
  • Create New...

Important Information

Terms of Use / Privacy Policy / Guidelines / We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.