Hello. I have a previously used server file that has a database. But for some reason the mysql server doesn't want to start... Can someone help me with this? Thank you in advance.
.err:
241223 18:20:56 mysqld_safe Logging to '/var/db/mysql/.err'.
241223 18:20:56 mysqld_safe Starting mysqld daemon with databases from /var/db/mysql
2024-12-23 18:20:56 0 [Warning] TIMESTAMP with implicit DEFAULT value is deprecated. Please use --explicit_defaults_for_timestamp server option (see documentation for more details).
2024-12-23 18:20:56 0 [Note] /usr/local/libexec/mysqld (mysqld 5.6.51) starting as process 3536 ...
2024-12-23 18:20:56 3536 [Note] Plugin 'FEDERATED' is disabled.
2024-12-23 18:20:56 3536 [Note] InnoDB: Using atomics to ref count buffer pool pages
2024-12-23 18:20:56 3536 [Note] InnoDB: The InnoDB memory heap is disabled
2024-12-23 18:20:56 3536 [Note] InnoDB: Mutexes and rw_locks use GCC atomic builtins
2024-12-23 18:20:56 3536 [Note] InnoDB: Memory barrier is not used
2024-12-23 18:20:56 3536 [Note] InnoDB: Compressed tables use zlib 1.2.12
2024-12-23 18:20:56 3536 [Note] InnoDB: Not using CPU crc32 instructions
2024-12-23 18:20:56 3536 [Note] InnoDB: Initializing buffer pool, size = 128.0M
2024-12-23 18:20:56 3536 [Note] InnoDB: Completed initialization of buffer pool
2024-12-23 18:20:56 3536 [Note] InnoDB: Highest supported file format is Barracuda.
2024-12-23 18:20:56 3536 [Note] InnoDB: The log sequence numbers 1600607 and 1600607 in ibdata files do not match the log sequence number 1600617 in the ib_logfiles!
2024-12-23 18:20:56 3536 [Note] InnoDB: Database was not shutdown normally!
2024-12-23 18:20:56 3536 [Note] InnoDB: Starting crash recovery.
2024-12-23 18:20:56 3536 [Note] InnoDB: Reading tablespace information from the .ibd files...
2024-12-23 18:20:56 20e6c000 InnoDB: Operating system error number 13 in a file operation.
InnoDB: The error means mysqld does not have the access rights to
InnoDB: the directory.
InnoDB: Error: could not open single-table tablespace file ./common/innodb_index_stats.ibd
InnoDB: We do not continue the crash recovery, because the table may become
InnoDB: corrupt if we cannot apply the log records in the InnoDB log to it.
InnoDB: To fix the problem and start mysqld:
InnoDB: 1) If there is a permission problem in the file and mysqld cannot
InnoDB: open the file, you should modify the permissions.
InnoDB: 2) If the table is not needed, or you can restore it from a backup,
InnoDB: then you can remove the .ibd file, and InnoDB will do a normal
InnoDB: crash recovery and ignore that table.
InnoDB: 3) If the file system or the disk is broken, and you cannot remove
InnoDB: the .ibd file, you can set innodb_force_recovery > 0 in my.cnf
InnoDB: and force InnoDB to continue crash recovery here.
241223 18:20:56 mysqld_safe mysqld from pid file /var/db/mysql/.pid ended