I get infinite connection refused on the console, and this is what I've in the syserr (I've censored my IP), that 3 ports if I'm correct should be the P2P, and it wasn't suggest to open them, anyway I opened them after I got the errors, but it still doesn't works, could it be the networked choosen on the VM that cause this problem (I've selected the bridge one, if I try the NAT it doesn't works at all.
I tried to use hamachi out of desperation, but after few seconds the server start to get a connection timed out (different from the previous attempt), I used portmap to open the ports, but unfortunately I get the same results when I try to log in, after the character select I get kicked out..
Do you know where I can find a complete guide for 40k files to set them up on my public IP or on hamachi, I tried to use DMZ too for my IP but it didn't worked..
EDIT2: So I tried to use the alternate method in that guide you linked, got the same exact error, but this time the IP was a 0:
Meanwhile I checked the previous log when I used hamachi and this appeared (censored the IP):
it seems that the recurring thing is that port, the rest of the syserr are identical on both version (localhost, publicIP and Hamachi) but both hamachi and public IP kick me after char select and infinite spam the console with timed out and connection refused, and the syserr have only that string repeated with that port, that I've opened like the other, I tried just for testing, to close every port, and it seems that i get all the same errors but with all the different ports that were open, so my port forwarding works on my router, but there's something strange with that specific ports 140xx..
Last EDIT:
Finally fixed it, to make it work I had to edit /etc/rc.conf assign a local static IP and disable the DHCP, open the router ports (P2P too) on for that static IP (that I assigned based on the MAC of the VM) use the first method in this guide
(The second method didn't worked at all), everything seems to work, thanks for everything.