Jump to content
Forgot your email address? ×
×
×
  • Create New...
  • 0

Someone already fixed the socket2 error with item_award?


Yiv

Question

Dear community,

 

as I found out that there's an error in player.item_award (or not directly in it but the function of it) I wanted to ask if someone already fixed it?

The error works as following:

- Itemshop writes the item into player.item_award with a socket2 value (e.g. 300 for a unique item as 5 hours using time)

- Player takes item but the socket2 is not written into player.item so the item doesn't have a use time (0 minutes)

- Item purges

 

If nobody fixed it maybe someone could fix it?

 

Regards

  • Love 1
Link to comment

2 answers to this question

Recommended Posts

  • 0
  • Premium

Well I have just searched for a topic like this, because I don't like to start a whole new topic for this small fix.

So, the problem is: you can't put stones into the 3rd socket (socket2) while using itemshop with item_award.
 
Open cilentmanager.cpp and search:

DWORD dwSocket2 = 0;

It is in the CClientManager::RESULT_SAFEBOX_LOAD function.

Then replace with this:

DWORD dwSocket2 = pItemAward->dwSocket2;

The problem caused because the dwSocket variable definied as 0, and only modified if (pItemTable->bType == ITEM_UNIQUE)

 

Have a nice day ;)

  • Love 2

The one and only UI programming guideline

Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Announcements

  • -15% Discount in Metin2 Dev Store (01/10/2021 => 31/12/2021) => Code => 15_PCT_OCT_TO_DEC_2021


Important Information

Terms of Use / Privacy Policy / Guidelines / We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.