Jump to content
×
×
  • Create New...
  • 0

Metin2 4inventory page bug (?)


TheSLZ

Question

Hi Metin2Dev
 
I have a little error with 4inventory page.
Sometimes i can't drop/equip/move items.
i need to restart the client to fix this. (But sometimes i click lots of and it's fix itself)
 
It's cause by i change some BYTE to int in char_item.cpp? (To make belt slots work with 4 inventory)
BYTE bCell = Cell.cell;         to         int bCell = Cell.cell;
(2x)
BYTE bPage = bCell / (INVENTORY_MAX_NUM / 4);         to         int bPage = bCell / (INVENTORY_MAX_NUM / 4);
(2x)
BYTE p = bCell + (5 * j);       to         int p = bCell + (5 * j);
 
 
Can anyone give me a solution?
 
Regards,
SLZ
Link to comment
Share on other sites

  • Answers 2
  • Created
  • Last Reply

Top Posters For This Question

Popular Days

Top Posters For This Question

2 answers to this question

Recommended Posts

  • 0

Syserr (client&server) is empty.

 

But i solved, i use P3NG3R's drop dialog, and it's written for 2 inv, i change this in uicommon.py:

if None == iPos or iPos >= 90 or iPos < 0:

to

if None == iPos or iPos >= 180 or iPos < 0:

 

And it's solved the bug.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


Important Information

Terms of Use / Privacy Policy / Guidelines / We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.