Jump to content
  • Create New...
  • 0

[Help] Meley Lair Bug





I'm trying to implement the Meley Lair in my server, but i'm having a problem during the course of the dungeon.


Basically, I implemented all the necessary files (server source, binary and models/maps/quest).

The files work, I can enter the dungeon and start it without problems. But in the course of it, after I put all statues at 50% HP, I supposedly need to kill 4 bosses and 4 eggstones to continue taking damage to the statues, but after I do this, nothing happers and all the hits i take to them say "miss"...
It seems that somehow the code isn't passing to the next step


I tried to check syserrs, both in the server and client side, but its empty...


I also tried to implement many versions of the files, incluiding new Meleylair.cpp + MeleyLair.h to the source, but the problem insists to continue.


Here is a video showing what happens:

(NOTE: The visual bugs of the statues and laser effects have been fixed, but it seems that there is no correlation with this bug)



Here's also the MeleyLair.cpp im using right know, in case you wan't to check it out:

This is the hidden content, please


I would appreciate very much if anyone knows how to fix this.


Thank you very much for your time.

  • Metin2 Dev 4
  • Good 1
Link to comment
Share on other sites

1 answer to this question

Recommended Posts

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    • No registered users viewing this page.

Important Information

Terms of Use / Privacy Policy / Guidelines / We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.