Jump to content

Recommended Posts

Hello metin2dev,


i have a problem about my mysql when i am rebooting the server the new tables getting crash and i cant open them


the problem starts when i deleted these files:

https://metin2.download/picture/r3F9504x09DVmF8K988YXgTtGTP6KMUj/.gif

now the syserr of root601841.kms4.cc.err

Spoiler

180118 18:20:23 mysqld_safe mysqld from pid file /var/db/mysql/root601841.kms4.cc.pid ended
180118 18:21:10 mysqld_safe Logging to '/var/db/mysql/root601841.kms4.cc.err'.
180118 18:21:10 mysqld_safe Starting mysqld daemon with databases from /var/db/mysql
2018-01-18 18:21:12 0 [Warning] TIMESTAMP with implicit DEFAULT value is deprecated. Please use --explicit_defaults_for_timestamp server option (see documentation for more details).
2018-01-18 18:21:12 0 [Note] /usr/local/libexec/mysqld (mysqld 5.6.38) starting as process 684 ...
2018-01-18 18:21:12 684 [Note] Plugin 'FEDERATED' is disabled.
/usr/local/libexec/mysqld: Table 'mysql.plugin' doesn't exist
2018-01-18 18:21:12 684 [ERROR] Can't open the mysql.plugin table. Please run mysql_upgrade to create it.
2018-01-18 18:21:12 684 [Note] InnoDB: Using atomics to ref count buffer pool pages
2018-01-18 18:21:12 684 [Note] InnoDB: The InnoDB memory heap is disabled
2018-01-18 18:21:12 684 [Note] InnoDB: Mutexes and rw_locks use GCC atomic builtins
2018-01-18 18:21:12 684 [Note] InnoDB: Memory barrier is not used
2018-01-18 18:21:12 684 [Note] InnoDB: Compressed tables use zlib 1.2.8
2018-01-18 18:21:12 684 [Note] InnoDB: Using CPU crc32 instructions
2018-01-18 18:21:12 684 [Note] InnoDB: Initializing buffer pool, size = 128.0M
2018-01-18 18:21:12 684 [Note] InnoDB: Completed initialization of buffer pool
2018-01-18 18:21:12 684 [Note] InnoDB: The first specified data file ./ibdata1 did not exist: a new database to be created!
2018-01-18 18:21:12 684 [Note] InnoDB: Setting file ./ibdata1 size to 12 MB
2018-01-18 18:21:12 684 [Note] InnoDB: Database physically writes the file full: wait...
2018-01-18 18:21:12 684 [Note] InnoDB: Setting log file ./ib_logfile101 size to 48 MB
2018-01-18 18:21:13 684 [Note] InnoDB: Setting log file ./ib_logfile1 size to 48 MB
2018-01-18 18:21:13 684 [Note] InnoDB: Renaming log file ./ib_logfile101 to ./ib_logfile0
2018-01-18 18:21:13 684 [Warning] InnoDB: New log files created, LSN=45781
2018-01-18 18:21:13 684 [Note] InnoDB: Doublewrite buffer not found: creating new
2018-01-18 18:21:13 684 [Note] InnoDB: Doublewrite buffer created
2018-01-18 18:21:13 684 [Note] InnoDB: 128 rollback segment(s) are active.
2018-01-18 18:21:13 684 [Warning] InnoDB: Creating foreign key constraint system tables.
2018-01-18 18:21:13 684 [Note] InnoDB: Foreign key constraint system tables created
2018-01-18 18:21:13 684 [Note] InnoDB: Creating tablespace and datafile system tables.
2018-01-18 18:21:13 684 [Note] InnoDB: Tablespace and datafile system tables created.
2018-01-18 18:21:13 684 [Note] InnoDB: Waiting for purge to start
2018-01-18 18:21:13 684 [Note] InnoDB: 5.6.38 started; log sequence number 0
2018-01-18 18:21:13 684 [Note] RSA private key file not found: /var/db/mysql//private_key.pem. Some authentication plugins will not work.
2018-01-18 18:21:13 684 [Note] RSA public key file not found: /var/db/mysql//public_key.pem. Some authentication plugins will not work.
2018-01-18 18:21:13 684 [Note] Server hostname (bind-address): '*'; port: 3306
2018-01-18 18:21:13 684 [Note] IPv6 is available.
2018-01-18 18:21:13 684 [Note]   - '::' resolves to '::';
2018-01-18 18:21:13 684 [Note] Server socket created on IP: '::'.
2018-01-18 18:21:13 684 [ERROR] Missing system table mysql.proxies_priv; please run mysql_upgrade to create it
2018-01-18 18:21:13 684 [ERROR] Can't open and lock privilege tables: Table 'mysql.servers' doesn't exist
2018-01-18 18:21:13 684 [ERROR] Native table 'performance_schema'.'cond_instances' has the wrong structure
2018-01-18 18:21:13 684 [ERROR] Native table 'performance_schema'.'events_waits_current' has the wrong structure
2018-01-18 18:21:13 684 [ERROR] Native table 'performance_schema'.'events_waits_history' has the wrong structure
2018-01-18 18:21:13 684 [ERROR] Native table 'performance_schema'.'events_waits_history_long' has the wrong structure
2018-01-18 18:21:13 684 [ERROR] Native table 'performance_schema'.'events_waits_summary_by_host_by_event_name' has the wrong structure
2018-01-18 18:21:13 684 [ERROR] Native table 'performance_schema'.'events_waits_summary_by_instance' has the wrong structure
2018-01-18 18:21:13 684 [ERROR] Native table 'performance_schema'.'events_waits_summary_by_thread_by_event_name' has the wrong structure
2018-01-18 18:21:13 684 [ERROR] Native table 'performance_schema'.'events_waits_summary_by_user_by_event_name' has the wrong structure
2018-01-18 18:21:13 684 [ERROR] Native table 'performance_schema'.'events_waits_summary_by_account_by_event_name' has the wrong structure
2018-01-18 18:21:13 684 [ERROR] Native table 'performance_schema'.'events_waits_summary_global_by_event_name' has the wrong structure
2018-01-18 18:21:13 684 [ERROR] Native table 'performance_schema'.'file_instances' has the wrong structure
2018-01-18 18:21:13 684 [ERROR] Native table 'performance_schema'.'file_summary_by_event_name' has the wrong structure
2018-01-18 18:21:13 684 [ERROR] Native table 'performance_schema'.'file_summary_by_instance' has the wrong structure
2018-01-18 18:21:13 684 [ERROR] Native table 'performance_schema'.'host_cache' has the wrong structure
2018-01-18 18:21:13 684 [ERROR] Native table 'performance_schema'.'mutex_instances' has the wrong structure
2018-01-18 18:21:13 684 [ERROR] Native table 'performance_schema'.'objects_summary_global_by_type' has the wrong structure
2018-01-18 18:21:13 684 [ERROR] Native table 'performance_schema'.'performance_timers' has the wrong structure
2018-01-18 18:21:13 684 [ERROR] Native table 'performance_schema'.'rwlock_instances' has the wrong structure
2018-01-18 18:21:13 684 [ERROR] Native table 'performance_schema'.'setup_actors' has the wrong structure
2018-01-18 18:21:13 684 [ERROR] Native table 'performance_schema'.'setup_consumers' has the wrong structure
2018-01-18 18:21:13 684 [ERROR] Native table 'performance_schema'.'setup_instruments' has the wrong structure
2018-01-18 18:21:13 684 [ERROR] Native table 'performance_schema'.'setup_objects' has the wrong structure
2018-01-18 18:21:13 684 [ERROR] Native table 'performance_schema'.'setup_timers' has the wrong structure
2018-01-18 18:21:13 684 [ERROR] Native table 'performance_schema'.'table_io_waits_summary_by_index_usage' has the wrong structure
2018-01-18 18:21:13 684 [ERROR] Native table 'performance_schema'.'table_io_waits_summary_by_table' has the wrong structure
2018-01-18 18:21:13 684 [ERROR] Native table 'performance_schema'.'table_lock_waits_summary_by_table' has the wrong structure
2018-01-18 18:21:13 684 [ERROR] Native table 'performance_schema'.'threads' has the wrong structure
2018-01-18 18:21:13 684 [ERROR] Native table 'performance_schema'.'events_stages_current' has the wrong structure
2018-01-18 18:21:13 684 [ERROR] Native table 'performance_schema'.'events_stages_history' has the wrong structure
2018-01-18 18:21:13 684 [ERROR] Native table 'performance_schema'.'events_stages_history_long' has the wrong structure
2018-01-18 18:21:13 684 [ERROR] Native table 'performance_schema'.'events_stages_summary_by_thread_by_event_name' has the wrong structure
2018-01-18 18:21:13 684 [ERROR] Native table 'performance_schema'.'events_stages_summary_by_account_by_event_name' has the wrong structure
2018-01-18 18:21:13 684 [ERROR] Native table 'performance_schema'.'events_stages_summary_by_user_by_event_name' has the wrong structure
2018-01-18 18:21:13 684 [ERROR] Native table 'performance_schema'.'events_stages_summary_by_host_by_event_name' has the wrong structure
2018-01-18 18:21:13 684 [ERROR] Native table 'performance_schema'.'events_stages_summary_global_by_event_name' has the wrong structure
2018-01-18 18:21:13 684 [ERROR] Native table 'performance_schema'.'events_statements_current' has the wrong structure
2018-01-18 18:21:13 684 [ERROR] Native table 'performance_schema'.'events_statements_history' has the wrong structure
2018-01-18 18:21:13 684 [ERROR] Native table 'performance_schema'.'events_statements_history_long' has the wrong structure
2018-01-18 18:21:13 684 [ERROR] Native table 'performance_schema'.'events_statements_summary_by_thread_by_event_name' has the wrong structure
2018-01-18 18:21:13 684 [ERROR] Native table 'performance_schema'.'events_statements_summary_by_account_by_event_name' has the wrong structure
2018-01-18 18:21:13 684 [ERROR] Native table 'performance_schema'.'events_statements_summary_by_user_by_event_name' has the wrong structure
2018-01-18 18:21:13 684 [ERROR] Native table 'performance_schema'.'events_statements_summary_by_host_by_event_name' has the wrong structure
2018-01-18 18:21:13 684 [ERROR] Native table 'performance_schema'.'events_statements_summary_global_by_event_name' has the wrong structure
2018-01-18 18:21:13 684 [ERROR] Native table 'performance_schema'.'events_statements_summary_by_digest' has the wrong structure
2018-01-18 18:21:13 684 [ERROR] Native table 'performance_schema'.'users' has the wrong structure
2018-01-18 18:21:13 684 [ERROR] Native table 'performance_schema'.'accounts' has the wrong structure
2018-01-18 18:21:13 684 [ERROR] Native table 'performance_schema'.'hosts' has the wrong structure
2018-01-18 18:21:13 684 [ERROR] Native table 'performance_schema'.'socket_instances' has the wrong structure
2018-01-18 18:21:13 684 [ERROR] Native table 'performance_schema'.'socket_summary_by_instance' has the wrong structure
2018-01-18 18:21:13 684 [ERROR] Native table 'performance_schema'.'socket_summary_by_event_name' has the wrong structure
2018-01-18 18:21:13 684 [ERROR] Native table 'performance_schema'.'session_connect_attrs' has the wrong structure
2018-01-18 18:21:13 684 [ERROR] Native table 'performance_schema'.'session_account_connect_attrs' has the wrong structure
2018-01-18 18:21:13 684 [ERROR] Column count of mysql.db is wrong. Expected 22, found 20. The table is probably corrupted
2018-01-18 18:21:13 684 [ERROR] Cannot open mysql.event
2018-01-18 18:21:13 684 [ERROR] Event Scheduler: An error occurred when initializing system tables. Disabling the Event Scheduler.
2018-01-18 18:21:13 684 [Note] /usr/local/libexec/mysqld: ready for connections.
Version: '5.6.38'  socket: '/tmp/mysql.sock'  port: 3306  Source distribution
2018-01-18 18:21:41 684 [Warning] InnoDB: Cannot open table anyshop/categories from the internal data dictionary of InnoDB though the .frm file for the table exists. See http://dev.mysql.com/doc/refman/5.6/en/innodb-troubleshooting.html for how you can resolve the problem.
2018-01-18 18:21:41 684 [Warning] InnoDB: Cannot open table anyshop/categories from the internal data dictionary of InnoDB though the .frm file for the table exists. See http://dev.mysql.com/doc/refman/5.6/en/innodb-troubleshooting.html for how you can resolve the problem.
2018-01-18 18:21:45 684 [Warning] InnoDB: Cannot open table homepage/ban_log from the internal data dictionary of InnoDB though the .frm file for the table exists. See http://dev.mysql.com/doc/refman/5.6/en/innodb-troubleshooting.html for how you can resolve the problem.
2018-01-18 18:21:45 684 [Warning] InnoDB: Cannot open table homepage/ban_log from the internal data dictionary of InnoDB though the .frm file for the table exists. See http://dev.mysql.com/doc/refman/5.6/en/innodb-troubleshooting.html for how you can resolve the problem.
2018-01-18 18:21:47 684 [Warning] InnoDB: Cannot open table homepage/psc_log from the internal data dictionary of InnoDB though the .frm file for the table exists. See http://dev.mysql.com/doc/refman/5.6/en/innodb-troubleshooting.html for how you can resolve the problem.
2018-01-18 18:21:47 684 [Warning] InnoDB: Cannot open table homepage/psc_log from the internal data dictionary of InnoDB though the .frm file for the table exists. See http://dev.mysql.com/doc/refman/5.6/en/innodb-troubleshooting.html for how you can resolve the problem.
2018-01-18 18:23:32 684 [Warning] InnoDB: Cannot open table homepage/psc_log from the internal data dictionary of InnoDB though the .frm file for the table exists. See http://dev.mysql.com/doc/refman/5.6/en/innodb-troubleshooting.html for how you can resolve the problem.
2018-01-18 18:26:01 684 [Warning] InnoDB: Cannot open table anyshop/categories from the internal data dictionary of InnoDB though the .frm file for the table exists. See http://dev.mysql.com/doc/refman/5.6/en/innodb-troubleshooting.html for how you can resolve the problem.
2018-01-18 18:26:01 684 [Warning] InnoDB: Cannot open table anyshop/categories from the internal data dictionary of InnoDB though the .frm file for the table exists. See http://dev.mysql.com/doc/refman/5.6/en/innodb-troubleshooting.html for how you can resolve the problem.
2018-01-18 18:26:04 684 [Warning] InnoDB: Cannot open table anyshop/shopitems from the internal data dictionary of InnoDB though the .frm file for the table exists. See http://dev.mysql.com/doc/refman/5.6/en/innodb-troubleshooting.html for how you can resolve the problem.
2018-01-18 18:26:04 684 [Warning] InnoDB: Cannot open table anyshop/shopitems from the internal data dictionary of InnoDB though the .frm file for the table exists. See http://dev.mysql.com/doc/refman/5.6/en/innodb-troubleshooting.html for how you can resolve the problem.
2018-01-18 18:27:12 829f77c00 InnoDB: Error: Table "mysql"."innodb_table_stats" not found.
2018-01-18 18:27:22 829f77c00 InnoDB: Error: Table "mysql"."innodb_table_stats" not found.
2018-01-18 18:27:22 829f77c00 InnoDB: Error: Table "mysql"."innodb_table_stats" not found.
2018-01-18 18:27:22 829f77c00 InnoDB: Error: Fetch of persistent statistics requested for table "homepage"."server_settings" but the required system tables mysql.innodb_table_stats and mysql.innodb_index_stats are not present or have unexpected structure. Using transient stats instead.
2018-01-18 18:27:32 80380b000 InnoDB: Error: Table "mysql"."innodb_table_stats" not found.
2018-01-18 18:27:32 80380b000 InnoDB: Recalculation of persistent statistics requested for table "homepage"."server_settings" but the required persistent statistics storage is not present or is corrupted. Using transient stats instead.
2018-01-18 18:27:44 829f77c00 InnoDB: Error: Table "mysql"."innodb_table_stats" not found.
2018-01-18 18:27:53 829f77c00 InnoDB: Error: Table "mysql"."innodb_table_stats" not found.
2018-01-18 18:28:12 829f77c00 InnoDB: Error: Table "mysql"."innodb_table_stats" not found.
2018-01-18 18:28:20 829f77c00 InnoDB: Error: Table "mysql"."innodb_table_stats" not found.
2018-01-18 18:28:48 829f76000 InnoDB: Error: Table "mysql"."innodb_table_stats" not found.
2018-01-18 18:28:48 829f76000 InnoDB: Error: Table "mysql"."innodb_table_stats" not found.
2018-01-18 18:28:48 829f76000 InnoDB: Error: Fetch of persistent statistics requested for table "anyshop"."categories" but the required system tables mysql.innodb_table_stats and mysql.innodb_index_stats are not present or have unexpected structure. Using transient stats instead.
2018-01-18 18:28:56 829f76000 InnoDB: Error: Table "mysql"."innodb_table_stats" not found.
2018-01-18 18:28:56 829f76000 InnoDB: Error: Table "mysql"."innodb_table_stats" not found.
2018-01-18 18:28:56 829f76000 InnoDB: Error: Fetch of persistent statistics requested for table "anyshop"."shopitems" but the required system tables mysql.innodb_table_stats and mysql.innodb_index_stats are not present or have unexpected structure. Using transient stats instead.
2018-01-18 18:29:03 829f76000 InnoDB: Error: Table "mysql"."innodb_table_stats" not found.
2018-01-18 18:29:03 829f76000 InnoDB: Error: Table "mysql"."innodb_table_stats" not found.
2018-01-18 18:29:03 829f76000 InnoDB: Error: Fetch of persistent statistics requested for table "anyshop"."shops" but the required system tables mysql.innodb_table_stats and mysql.innodb_index_stats are not present or have unexpected structure. Using transient stats instead.
2018-01-18 18:29:06 80380b000 InnoDB: Error: Table "mysql"."innodb_table_stats" not found.
2018-01-18 18:29:06 80380b000 InnoDB: Recalculation of persistent statistics requested for table "anyshop"."shopitems" but the required persistent statistics storage is not present or is corrupted. Using transient stats instead.
2018-01-18 18:29:16 80380b000 InnoDB: Error: Table "mysql"."innodb_table_stats" not found.
2018-01-18 18:29:16 80380b000 InnoDB: Recalculation of persistent statistics requested for table "anyshop"."categories" but the required persistent statistics storage is not present or is corrupted. Using transient stats instead.
2018-01-18 18:32:14 829f76000 InnoDB: Error: Table "mysql"."innodb_table_stats" not found.
2018-01-18 18:32:14 829f76000 InnoDB: Error: Fetch of persistent statistics requested for table "anyshop"."shopitems" but the required system tables mysql.innodb_table_stats and mysql.innodb_index_stats are not present or have unexpected structure. Using transient stats instead.
2018-01-18 18:32:14 829f76000 InnoDB: Error: Table "mysql"."innodb_table_stats" not found.
2018-01-18 18:32:14 829f76000 InnoDB: Error: Fetch of persistent statistics requested for table "anyshop"."shops" but the required system tables mysql.innodb_table_stats and mysql.innodb_index_stats are not present or have unexpected structure. Using transient stats instead.
2018-01-18 18:32:14 829f76000 InnoDB: Error: Table "mysql"."innodb_table_stats" not found.
2018-01-18 18:32:14 829f76000 InnoDB: Error: Fetch of persistent statistics requested for table "anyshop"."categories" but the required system tables mysql.innodb_table_stats and mysql.innodb_index_stats are not present or have unexpected structure. Using transient stats instead.
 


can you please tell me what can i do to fix it?

(sorry for my english hope you unterstand my problem)

Edited by Metin2 Dev
Core X - External 2 Internal
  • Replies 0
  • Created
  • Last Reply

Top Posters In This Topic

Popular Days

Top Posters In This Topic

Don't use any images from : imgur, turkmmop, freakgamers, inforge, hizliresim... Or your content will be deleted without notice...
Use : https://metin2.download/media/add/

Please use https://metin2.download/ when uploading files smaller than 100MB, otherwise the approval will take longer due to manual upload.

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now
×
×
  • Create New...

Important Information

Terms of Use / Privacy Policy / Guidelines / We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.