Jump to content
×
×
  • Create New...
  • 0

safe_create: calloc failed[12]


unberkante

Question

Hello, I have a functionnal environment wich only work when I don't use my own game/db. I tried to compile the game/db with several source but I always get the same error in sysser:

Start of pid: 1238
SYSERR: Jun 11 02:10:32 :: safe_create: calloc failed [12] Cannot allocate memory
SYSERR: Jun 11 02:10:32 :: buffer_new: calloc failed [12] Cannot allocate memory

It's the first sysser message at startup(the only one). it comes from the game and I get a game.core wich keep growing until i reboot.

I counted the number of call to the CREATE function wich call calloc and it makes 1216 call to calloc with a size of 1mo each time. but I don't know why it calls it.

I'm compiling with gcc49 on freebsd11 here is an output from gdb :

380698Sanstitre.png

If someone could help me I would be gratefull, thanks in advence !

Link to comment
Share on other sites

  • Answers 1
  • Created
  • Last Reply

Top Posters For This Question

Top Posters For This Question

1 answer to this question

Recommended Posts

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    • No registered users viewing this page.


Important Information

Terms of Use / Privacy Policy / Guidelines / We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.