Jump to content

Sokus

Inactive Member
  • Posts

    6
  • Joined

  • Last visited

  • Feedback

    0%

About Sokus

Informations

  • Gender
    Male
  • Country
    Poland
  • Nationality
    Polish

Recent Profile Visitors

The recent visitors block is disabled and is not being shown to other users.

Sokus's Achievements

Apprentice

Apprentice (3/16)

  • One Year In
  • One Month Later
  • Week One Done
  • Dedicated
  • Reacting Well

Recent Badges

0

Reputation

  1. I had to remove boost-system and libmysql from vcpkg install for it to progress further (both were depending on Boost), CPMAddPackage seems to be working for Boost - how can I do the same for libmysql? CMake is throwing errors because it cannot find unofficial-libmysql.
  2. I've meant docker build, not docker compose - couldn't find a way to edit the original message.
  3. What is the current preferred way to get this running? I've tried the docker method but it throws errors after running docker compose. On default (master) branch I quite quickly get errors while vcpkg installs boost: [Hidden Content] When checked out to nightly branch it runs for much longer but eventually I get errors because "flame_dungeon.quest" is missing: [Hidden Content] I've also tried checking out to the 0.2.2 tag but it fails almost instantly (no candidate found for python2 package) so I won't even post the output. PS. If there is a better place to discuss/debug, for example some sort of discord server I would be glad to join - I've got an invitation but it expired on me
  4. I really like this idea, I host a server just for me and my friends so the "Imagine being able to take a small Raspberry Pi and host a Metin2 server on it" part really speaks to me I have experience with C, networking and old school gamedev with my own projects but never contributed to anything bigger so I would like to learn some more - if that is okay I would also like the discord server invitation
  5. ZeroTier was the way, I created a clean machine, installed ZeroTier by typing: pkg install zerotier, then added: zerotier_enable="YES" to /etc/rc.conf, and used the IP address from the virtual network adapter in the client.
  6. It is my second attempt at launching a server, the first one was with this guide (metin2 project, only FR), and now using [40250] Reference Serverfiles. I followed instructions in one of the comments to set it up for hamachi (I am using RadminVPN), but my friend is unable to join (it works locally). We both have our firewalls turned off. What could be the issue? EDIT: I did find some more info, I will try using ZeroTier on the FreeBSD virtual machine - didn't find anything about the setup yet, so any tips are always welcome.
×
×
  • Create New...

Important Information

Terms of Use / Privacy Policy / Guidelines / We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.