Don't edit your reply saying you resolved an error without even explaining how you resolved it. Until you explain that you won't get any further help, howabout that?
Yeah you are right to be honest i dont even know how i solved that, cause i did so many things, like delete and start again with, i delete the mysql folder and put it on again, next if i remember correctly i rebooted my machine went to putty and tried installing everything install.sh as the metin2 user, gave chown -R metin2 . in every folder of /var/db /var/db/mysql and somehow i rebooted again and started working, kinda strange, i didn't want to post this as the solution cause i was not sure of what i did exactly, now if you could help me with my problem my host isn't allowed on the mysql server i would really appreciate.