Jump to content
  • 0

FreeBSD 9.2 x64 32bit libs wont work with the 40k game


Dr.Heisenberg

Question

yo guys can u pls help my

 

i tryed to install the 32bit libs but my server still dont start...

 

 

Shared object "libz.so.4" not found, required by "db"
: not found

Shared object "libmd.so.4" not found, required by "game"
: not found

 

 

Hopefully any one can help me ... and hopyfully not every one is playing watchdogs :P

Link to comment

12 answers to this question

Recommended Posts

  • 0

i had this problem with vanilla game and db

and to fix it i reinstalled compatx7

that  seem to be incompleat + lib32

for lib32

fetch ftp://ftp.freebsd.org/pub/FreeBSD/releases/amd64/amd64/9.1-RELEASE/lib32.txz
tar Jxpvf lib32.txz -C /
rm lib32.txz

then

cd /usr/ports/misc/compat7x && make deinstall
cd /usr/ports/misc/compat7x && make -DBATCH install clean

it should work

 

but i realy want to know what

-TÜRK-

said !! ^^ please dont get the wrong idia

  • Love 3
Link to comment
  • 0
140527 17:43:45 mysqld_safe mysqld restarted
2014-05-27 17:43:49 0 [Warning] TIMESTAMP with implicit DEFAULT value is deprecated. Please use --explicit_defaults_for_timestamp server option (see documentation for more details).
2014-05-27 17:43:49 38746 [Note] Plugin 'FEDERATED' is disabled.
/usr/local/libexec/mysqld: Table 'mysql.plugin' doesn't exist
2014-05-27 17:43:49 38746 [ERROR] Can't open the mysql.plugin table. Please run mysql_upgrade to create it.
2014-05-27 17:43:49 38746 [Note] InnoDB: Using atomics to ref count buffer pool pages
2014-05-27 17:43:49 38746 [Note] InnoDB: The InnoDB memory heap is disabled
2014-05-27 17:43:49 38746 [Note] InnoDB: Mutexes and rw_locks use GCC atomic builtins
2014-05-27 17:43:49 38746 [Note] InnoDB: Compressed tables use zlib 1.2.3
2014-05-27 17:43:49 38746 [Note] InnoDB: Not using CPU crc32 instructions
2014-05-27 17:43:49 38746 [Note] InnoDB: Initializing buffer pool, size = 128.0M
2014-05-27 17:43:49 38746 [Note] InnoDB: Completed initialization of buffer pool
2014-05-27 17:43:50 38746 [Note] InnoDB: Highest supported file format is Barracuda.
2014-05-27 17:43:50 38746 [Note] InnoDB: Log scan progressed past the checkpoint lsn 1688143
2014-05-27 17:43:50 38746 [Note] InnoDB: Database was not shutdown normally!
2014-05-27 17:43:50 38746 [Note] InnoDB: Starting crash recovery.
2014-05-27 17:43:50 38746 [Note] InnoDB: Reading tablespace information from the .ibd files...
2014-05-27 17:43:50 38746 [Note] InnoDB: Restoring possible half-written data pages 
2014-05-27 17:43:50 38746 [Note] InnoDB: from the doublewrite buffer...
InnoDB: Doing recovery: scanned up to log sequence number 1700933
2014-05-27 17:43:50 38746 [Note] InnoDB: 128 rollback segment(s) are active.
2014-05-27 17:43:50 38746 [Note] InnoDB: Waiting for purge to start
2014-05-27 17:43:50 38746 [Note] InnoDB: 5.6.17 started; log sequence number 1700933
2014-05-27 17:43:50 38746 [Note] Server hostname (bind-address): '*'; port: 3306
2014-05-27 17:43:50 38746 [Note] IPv6 is available.
2014-05-27 17:43:50 38746 [Note]   - '::' resolves to '::';
2014-05-27 17:43:50 38746 [Note] Server socket created on IP: '::'.
15:43:50 UTC - mysqld got signal 11 ;
This could be because you hit a bug. It is also possible that this binary
or one of the libraries it was linked against is corrupt, improperly built,
or misconfigured. This error can also be caused by malfunctioning hardware.
We will try our best to scrape up some info that will hopefully help
diagnose the problem, but since we have already crashed, 
something is definitely wrong and this may fail.
Link to comment
  • 0

the mysql problem happen to me many time (more then 20 time last week) i think thats because the orginal mysql file has been changed

the best solution is to rebuilt it as Shogun said and give it a other user and pass

to install the mysql server 56:

cd /usr/ports/databases/mysql56-server
make BUILD_OPTIMIZED=yes BUILD_STATIC=yes
make WITH_XCHARSET=all install clean

then

ee /etc/rc.conf

make sure that this line is written

mysql_enable="YES"

to give root it password

service mysql-server start
/usr/local/bin/mysqladmin -uroot password 'enterpassword'

change 'enterpassword' by your pass word it should look like this

/usr/local/bin/mysqladmin -uroot password metin2dev

in this case metin2dev is the pass for mysql-server

then

mysql -p
GRANT ALL PRIVILEGES ON *.* TO 'rumor'@'%'
IDENTIFIED BY 'password' WITH GRANT OPTION;
GRANT ALL PRIVILEGES ON *.* TO 'metin2'@'localhost'
IDENTIFIED BY 'password' WITH GRANT OPTION;
quit

here rumor is the account you should use if you have a root server

some may have the question why not using root

well its highly recommended not to use root nor for mysql nor sftp nor ftp nor ssh

ah and change 'password' with your 'passwordhere'

and good luck

thanks to Rumor for his topic here

Link to comment
  • 0

i had this problem with vanilla game and db

and to fix it i reinstalled compatx7

that  seem to be incompleat + lib32

for lib32

fetch ftp://ftp.freebsd.org/pub/FreeBSD/releases/amd64/amd64/9.1-RELEASE/lib32.txz
tar Jxpvf lib32.txz -C /
rm lib32.txz

then

cd /usr/ports/misc/compat7x && make deinstall
cd /usr/ports/misc/compat7x && make -DBATCH install clean

it should work

 

but i realy want to know what

-TÜRK-

said !! ^^ please dont get the wrong idia

i had the problem too, thank u TURK, it's working

Link to comment
  • 0

the mysql problem happen to me many time (more then 20 time last week) i think thats because the orginal mysql filearrow-10x10.png has been changed

the best solution is to rebuilt it as Shogun said and give it a other user and pass

to installarrow-10x10.png the mysql server 56:

cd /usr/ports/databases/mysql56-server
make BUILD_OPTIMIZED=yes BUILD_STATIC=yes
make WITH_XCHARSET=all install clean

then

ee /etc/rc.conf

make sure that this line is written

mysql_enable="YES"

to give root it password

service mysql-server start
/usr/local/bin/mysqladmin -uroot password 'enterpassword'

change 'enterpassword' by your pass word it should look like this


/usr/local/bin/mysqladmin -uroot password metin2dev

in this case metin2dev is the pass for mysql-server

then

mysql -p
GRANT ALL PRIVILEGES ON *.* TO 'rumor'@'%'
IDENTIFIED BY 'password' WITH GRANT OPTION;
GRANT ALL PRIVILEGES ON *.* TO 'metin2'@'localhost'
IDENTIFIED BY 'password' WITH GRANT OPTION;
quit

here rumor is the accountarrow-10x10.png you should use if you have a root server

some may have the question why not using root

well its highly recommended not to use root nor for mysql nor sftp nor ftp nor ssh

ah and change 'password' with your 'passwordhere'

and good luck

thanks to Rumor for his topic here

night i have problem on mysql too i followed this but say

/usr/local/bin/mysqladmin: connect to server at 'localhost' failed
error: 'Access denied for user 'root'@'localhost' (using password: NO)'

 

 
Link to comment
  • 0
  • VIP

the mysql problem happen to me many time (more then 20 time last week) i think thats because the orginal mysql filearrow-10x10.png has been changed

the best solution is to rebuilt it as Shogun said and give it a other user and pass

to installarrow-10x10.png the mysql server 56:

cd /usr/ports/databases/mysql56-server
make BUILD_OPTIMIZED=yes BUILD_STATIC=yes
make WITH_XCHARSET=all install clean

then

ee /etc/rc.conf

make sure that this line is written

mysql_enable="YES"

to give root it password

service mysql-server start
/usr/local/bin/mysqladmin -uroot password 'enterpassword'

change 'enterpassword' by your pass word it should look like this


/usr/local/bin/mysqladmin -uroot password metin2dev

in this case metin2dev is the pass for mysql-server

then

mysql -p
GRANT ALL PRIVILEGES ON *.* TO 'rumor'@'%'
IDENTIFIED BY 'password' WITH GRANT OPTION;
GRANT ALL PRIVILEGES ON *.* TO 'metin2'@'localhost'
IDENTIFIED BY 'password' WITH GRANT OPTION;
quit

here rumor is the accountarrow-10x10.png you should use if you have a root server

some may have the question why not using root

well its highly recommended not to use root nor for mysql nor sftp nor ftp nor ssh

ah and change 'password' with your 'passwordhere'

and good luck

thanks to Rumor for his topic here

night i have problem on mysql too i followed this but say

/usr/local/bin/mysqladmin: connect to server at 'localhost' failed
error: 'Access denied for user 'root'@'localhost' (using password: NO)'

 

 

service mysql-server stop

pwd_mkdb -p /etc/master.passwd
chown -R mysql /var/db/mysql && chgrp -R mysql /var/db/mysql
ervice mysql-server start
/usr/local/bin/mysqladmin -uroot password 'enterpassword'
Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


×
×
  • Create New...

Important Information

Terms of Use / Privacy Policy / Guidelines / We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.