Jump to content
  • 0

game compiling error (gcc49)


DaNy3LL

Question

Hi guys, I tried to compile the vanilla game source, but it fails at linking

 

First I re-compiled cryptopp from Extern folder with gcc49 , I got an error when I tried to compile the game , but I managed to fix the error by modifying some cryptopp files like this. But it still won't compile.

 

This was the error

../../../Extern/include/cryptopp/secblock.h:91:14: error: 'CheckSize' was not declared in this scope, and no declarations were found by argument-dependent lookup at the point of instantiation [-fpermissive]
CheckSize(n);

I think the p roblem is from cryptopp

 

Here is the compile log

 

Here is the makefile

 

How can I fix it ?

 

Kind Regards , DaNy3LL

Link to comment
  • Answers 5
  • Created
  • Last Reply

Top Posters For This Question

5 answers to this question

Recommended Posts

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


×
×
  • Create New...

Important Information

Terms of Use / Privacy Policy / Guidelines / We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.