Jump to content
  • 0
Sign in to follow this  
chrizz

Preload notxt.lib

Question

Hey,

 

how do i set the notxt-lib   while using this vrunner stuff?

"env LD_PRELOAD=/usr/home/game/share/libdb_notxt.so ./game"

 i used with the 2089 for other libs.

 

but in 34k

#!/bin/sh
./vrunner --daemon --pid-path=pid.db --file=db >> autorun.log 2>&1 &

so where is here to set env LD_PRELOAD=/usr/home/game/share/libdb_notxt.so

Share this post


Link to post

3 answers to this question

Recommended Posts

  • 0

Hi, I have 34k files and to to start it, I do it normaly and it run:

LIBS="/rute/to/lib/libname.so /rute/to/other/lib.so"
cd /rute/to/core && env LD_PRELOAD="$LIBS" ./game &

You only need to put the rute to libs in the LIBS="#here#" and it's all, describe your problem a little more, the servers starts or not? syserr? it hooks?

Share this post


Link to post
  • 0

the Problem is  i dont use the same start script as you,    as i said above im running with vrunner.pid

 

In every single core i have this start script

#!/bin/sh
./vrunner --daemon --pid-path=pid.db --file=db >> autorun.log 2>&1 &
 
so tell me where should i put here the lib Preload?
 
i Know how to preloaf LIB  when starting without ./vrunner.  ( without vrunner is the method you use)
 

 

Share this post


Link to post
  • 0
./vrunner --daemon --pid-path=pid.db --file=db --env="LD_PRELOAD=/path/to/libdb_notxt.so" >> autorun.log 2>&1 &

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  
  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...

Important Information

Terms of Use / Privacy Policy / Guidelines / We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.