Jump to content
  • 0

Running the game on dedicated gpu


Speachless

Question

  • VIP

No matter the settings i do make i can't run my server on the dedicated laptop's gpu. However, i've seen one server that runs directly on gpu with no problems.

 

I am paying for this.

Link to post

4 answers to this question

Recommended Posts

  • 0

That's because your client have directx8 (it's an entire explanation somewhere on stackoverflow).

That server you saw that run directly on GPU have directx9 (you talking about wom probably).

I tried to force the metin on GPU some time ago but you simply can't do it without upgrading to directx9.

  • Metin2 Dev 1
Link to post
  • 0
  • VIP
37 minutes ago, Johnny69 said:

That's because your client have directx8 (it's an entire explanation somewhere on stackoverflow).

That server you saw that run directly on GPU have directx9 (you talking about wom probably).

I tried to force the metin on GPU some time ago but you simply can't do it without upgrading to directx9.

 

Thank you

Link to post
  • 0
  • VIP

add this to your UserInterface.cpp;

 

// Force dedicated GPU
extern "C" {
    _declspec(dllexport) DWORD NvOptimusEnablement = 0x00000001;
    __declspec(dllexport) int AmdPowerXpressRequestHighPerformance = 1;
}

 

can't say if it works or not

Link to post
  • 0
  • VIP
Posted (edited)

It requires directx9. You can upgrade your source to dx9 or you can use a temporary upgrade from reshade (the dx8 to dx9 wrapper) 

 

 

Edited by Speachless
Link to post
Guest
This topic is now closed to further replies.


Shoutbox

Shoutbox

Chatroom Rules

 

Join our Discord

A request for help = Shoutbox Ban

Be respectful & Respect the rules

 

×
×
  • Create New...

Important Information

Terms of Use / Privacy Policy / Guidelines / We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.