Jump to content
  • 0

Problem with virtualbox (autobooting)


Creo

Question

4 answers to this question

Recommended Posts

  • 0
  • VIP
2 hours ago, Creo said:

How can I reset root password at virtualbox freebsd 9.2? I don't remember it

Just use command passwd I think

 

Edit: I think you meant reset not changing, I missunderstood you

anyway to reset see freebsd faq:

https://www.freebsd.org/doc/en/books/faq/admin.html#idp49286264

 

but in virtualbox you don't have to write "boot -s" to enter single-user mode, you can just enter it by clicking the number beside "Single User Mode" to enter it

Edited by Asentrix (see edit history)
Link to post
  • 0

Combining rare usage of the root password with a reluctance to store it in a password manager could be a recipe for disaster. It would be a tremendous shame to have to reinstall an OS just because of a failure to remember a password. Luckily, there are often ways around this problem. In FreeBSD, you should be able to recover root access when you have forgotten the root password by following these steps:

 

 

  1. Restart the system.
  2. At the boot: prompt, enter boot -s to enter Single User Mode.
  3. When asked what shell to use, press the Enter key.
  4. Because the root filesystem will be mounted read-only by default, you will need to remount it using the mount -ruw / command to give yourself read/write access.
  5. Run mount -a to remount all filesystems specified in the /etc/fstab file.
  6. Run passwd root to set a new root password.
  7. Run exit to continue booting normally.
Link to post
  • 0
6 hours ago, Kafa said:

Combining rare usage of the root password with a reluctance to store it in a password manager could be a recipe for disaster. It would be a tremendous shame to have to reinstall an OS just because of a failure to remember a password. Luckily, there are often ways around this problem. In FreeBSD, you should be able to recover root access when you have forgotten the root password by following these steps:

 

 

  1. Restart the system.
  2. At the boot: prompt, enter boot -s to enter Single User Mode.
  3. When asked what shell to use, press the Enter key.
  4. Because the root filesystem will be mounted read-only by default, you will need to remount it using the mount -ruw / command to give yourself read/write access.
  5. Run mount -a to remount all filesystems specified in the /etc/fstab file.
  6. Run passwd root to set a new root password.
  7. Run exit to continue booting normally.

passwd: root: no such user

22 hours ago, Asentrix said:

Just use command passwd I think

 

Edit: I think you meant reset not changing, I missunderstood you

anyway to reset see freebsd faq:

https://www.freebsd.org/doc/en/books/faq/admin.html#idp49286264

 

but in virtualbox you don't have to write "boot -s" to enter single-user mode, you can just enter it by clicking the number beside "Single User Mode" to enter it

yeah exactly nothing works and i just want to log in for 5 minutes so i can export my source code.......

Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Answer this question...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.



×
×
  • Create New...

Important Information

Terms of Use / Privacy Policy / Guidelines / We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.