Jump to content
  • Register Now

    Sign up and take advantage of the features of our community! Some forums are only accessible to our members!

  • 0

regen.txt weird bug


Cripplez
Go to solution Solved by Syreldar,

Question

Version of Files XXX

Hello, I tried to add the regen.txt in a new map, i added the same regen (with differenct coord) of another map with the same group vnum but when i start the server i have this syserr

SYSERR: Jul 14 19:16:26 :: SpawnMob: SpawnMob: no mob data for vnum 3031
SYSERR: Jul 14 19:16:26 :: SpawnMob: SpawnMob: no mob data for vnum 3031
SYSERR: Jul 14 19:16:26 :: SpawnMob: SpawnMob: no mob data for vnum 3031
SYSERR: Jul 14 19:16:26 :: SpawnMob: SpawnMob: no mob data for vnum 3031
SYSERR: Jul 14 19:16:26 :: SpawnMob: SpawnMob: no mob data for vnum 3031
SYSERR: Jul 14 19:16:26 :: SpawnMob: SpawnMob: no mob data for vnum 3031

I can't understand why in a map there are no problem with this group, in the other it says this, like it is trying to spawn the mob 3031 (that in fac doesn't exist) instead of spawning the group vnum

Anyone else had this problem?

 

Edited by Cripplez (see edit history)
Link to post

4 answers to this question

Recommended Posts

  • 1
  • Developer
  • Solution
34 minutes ago, Cripplez said:

 


I will explain better, it's impossible what is happening to me..
this is for example the regen.txt of the bayblack map and everything is okay, it is spawning the group 3023
fgtaEyu.png

If i try to use the same group vnum in the regen.txt of the new map, like this:

mbg4t9U.png

 

When i start the server i will have this error in the syserr:
SYSERR: Jul 14 19:16:26 :: SpawnMob: SpawnMob: no mob data for vnum 3023

 

But in the baybalck map everything is ok, in the other map there are no mob

 

If i try to use "g" instead of "r" for example with the group mob vnum 3023 i will receive the same syserr error and if i try to use "g" and the mob vnum 101 (the same group for wolves of village 1) instead of the group of mobs it will spawn only the mob 101, not the group

the stone.txt and boss.txt is working okay for metin stones and bosses, just regen.txt not

You're not giving random coordinate spaces to them, you cannot use 0 and 0 as randx and randy, min. 1 for both.

 

aipzcL3.png

👑 Premium Lua Developer 👑

 My service topic: https://bit.ly/2UPly54

 

Ignorant people have the obligation to compensate their ignorance by paying those who help them.

-Syreldar

Link to post
  • 0

Can you provide the code?

 

Otherwise it is not possible, if you copy-paste a regen.txt and only changing coords then it will work and you miss something.

Maybe stone, boss npc.txt have that 3031 and you had this syserr for a long time just only now noticing it? 

 

 

Edited by TMP4 (see edit history)
Link to post
  • 0
  • Developer

you're using the arg "m" instead of "g" in the regen, so it tries to spawn the mob instead of a group.

👑 Premium Lua Developer 👑

 My service topic: https://bit.ly/2UPly54

 

Ignorant people have the obligation to compensate their ignorance by paying those who help them.

-Syreldar

Link to post
  • 0
Posted (edited)
53 minutes ago, TMP4 said:

Can you provide the code?

 

Otherwise it is not possible, if you copy-paste a regen.txt and only changing coords then it will work and you miss something.

Maybe stone, boss npc.txt have that 3031 and you had this syserr for a long time just only now noticing it? 

 

 

 

48 minutes ago, Syreldar said:

you're using the arg "m" instead of "g" in the regen, so it tries to spawn the mob instead of a group.


I will explain better, it's impossible what is happening to me..
this is for example the regen.txt of the bayblack map and everything is okay, it is spawning the group 3023
fgtaEyu.png

If i try to use the same group vnum in the regen.txt of the new map, like this:

mbg4t9U.png

 

When i start the server i will have this error in the syserr:
SYSERR: Jul 14 19:16:26 :: SpawnMob: SpawnMob: no mob data for vnum 3023

 

But in the baybalck map everything is ok, in the other map there are no mob

 

If i try to use "g" instead of "r" for example with the group mob vnum 3023 i will receive the same syserr error and if i try to use "g" and the mob vnum 101 (the same group for wolves of village 1) instead of the group of mobs it will spawn only the mob 101, not the group

the stone.txt and boss.txt is working okay for metin stones and bosses, just regen.txt not

 

 

 

 

**** FIXED ****

I tested more and found what cause this "bug"

 

in the regen.txt if the vnum group has  0   0   after the coordinate they will not spawn, i tried again with setting 10   10 like this
33YxfEI.png


and now everything is good

Edited by Cripplez (see edit history)
Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


×
×
  • Create New...

Important Information

Terms of Use / Privacy Policy / Guidelines / We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.