Jump to content
  • We need you!

    You must register to discover all the features of our community!

  • 0

Google Cloud Platform Metin2 Hosting problem


Shahin

Question

Posted (edited)

Version of Files XXX

Hello, I wanted to start working at a big project using GCP as my host, on a 4 Cpu cores and 3.6Gb ram Machine (FREE SERVICES for 300$ or 1year of use, which comes first). I configured everything, mysql working just fine, connection to navicat working, server showing good life without errors (tested only ch1). And the problem comes NOW:

 

1. Description of the problem / Question :

Can't connect the client to the server / I cannot log in and it doesn't show Channel Status as being Online.

i have tried external ip and.. nothing. Tried internal ip and.. nothing

Bind_ip & Proxy IP with modified source and nothing. Link below with what i have attempted:

https://funky-emu.net/topic/23304-c-installer-un-proxy-ip-sur-votre-game/

 

2. SysErr ( Client / Server ) / SysLog ( Server )

Client side Syserr- nothing

Server side Syserr- nothing

Server is working fine, everything is UP and running. 

 

3. How to reproduce it ?

1. Create a Freebsd VM https://console.cloud.google.com/compute/ , and try uploading any server that you know it works fine. 

2. When creating a new instance, In the left side of your page  you will find 'Marketplace' R8ebUnl.png and search FreeBSD 12.1 

3. Set up for Germany as Local Internet for lowest Europe latency

4. To set up the FreeBSD for metin2, make this steps : https://www.elitepvpers.com/forum/metin2-pserver-guides-strategies/3544065-how-prepare-freebsd-metin2.html

5. To remote connect via putty/winscp, watch the video below.

6. To be able to drag and drop files in the server through winscp such as mysql.tar.gz, you need to switch user to root 

( sudo su - ) and give folder full user permissions with CHMOD 777 folder_location

7. Keep in mind that you need to change the TCP port from 3386 to 3306 in Network - Firewall section of GCP to make your NAVICAT work.

 

If anyone can help me via discord to find the solution faster, i would appreciate it.

The problem is network configuration for sure.

 

Thanks, Sincerly,
Shahin

 

 

DISCORD Revenge Arena#4229

 

Edited by Shahin
update (see edit history)
Link to post

3 answers to this question

Recommended Posts

  • 0
Posted (edited)
8 hours ago, Karbust said:

Google Cloud and AWS both use VM's, like you use on your computer. So the principle is the same, you can't pass the login phase.

 

This works: https://funky-emu.net/topic/23304-c-installer-un-proxy-ip-sur-votre-game/

 

I've tested it myself on AWS, Google Cloud is the same.

 

Thank you for your help, Karbust

 

I have tried the steps from the link, compiled the source with the new modifications and set-up the configs with

BIND_IP: Local IP  &  PROXY_IP: External IP

Still Nothing...

 

Can you help me with a hand via DIscord? I would appreciate it. This problem has wasted a few weeks of mine already..

Spoiler

 

( I also have another question with "why does mysql service not running" after i start the game ? aka rc.config/network config problem ? 

zAI5hkr.png

but this is a new topic:

I have tried on another dedicated server and the login process was successful, but i could've open only 1 channel and the mysql service went down immediately (that means no available way to open more than one channel). The same serverfile tried on Local VM (VB) and no problem with the mysql service what so ever either with 4 channels opened, the service was still running with pid x )

 

 

Thank you

 

Edited by Shahin (see edit history)
Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


×
×
  • Create New...

Important Information

Terms of Use / Privacy Policy / Guidelines / We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.