Jump to content
  • We need you!

    You must register to discover all the features of our community!

  • 0

locale_string.txt ENCODING PROBLEM


GoldCash

Question

Hi community,
I have such a pretty tricky problem with locale_string.txt, I need to translate the word into Czech, which means I have to have diacritics in this file. I can easily save this file as UTF8, but the server always takes the original translation, but if I leave it in the EUC-KR encoding, the translation will remain without diacritics..


Could you help me with this problem?

Link to post

5 answers to this question

Recommended Posts

  • 0
2 minutes ago, Kafa said:

you need to use the relative locale for correct charset 

It doesn't matter what I use it always happens the same thing

Link to post
  • 0
Posted (edited)
3 hours ago, GoldCash said:

Hi community,
I have such a pretty tricky problem with locale_string.txt, I need to translate the word into Czech, which means I have to have diacritics in this file. I can easily save this file as UTF8, but the server always takes the original translation, but if I leave it in the EUC-KR encoding, the translation will remain without diacritics..


Could you help me with this problem?

 

Hey there, I had same issue and i managed to solve it by replacing the locale_string.txt with my original one (untouched). After I opened it only with internal notepad made the editing and it worked out, not only cz, but several other languages with diacritics  like tr de it etc... (never use notepad ++ or other editor on locale_string, ONLY use internal winscp editor)

Edit: oh, one more thing ... dont download the locale_string on your pc/laptop etc, do the editing on server side.

This is not a fix, but it solve my problem, and I hope it will solve your's as well. 

Edited by joint4 (see edit history)
Link to post
  • 0
Posted (edited)

UTF8? For Czech?! xd

Try use brain...

Use charset windows1250 (Central European) and save as charset no instadead save..


Edit: CZ - UTF8 neumí diakritiku je to mezinárodní univerzal.. Musíš použít charset co jsem ti napsal a před zápisem prvně otevři locale_string.txt - já používám sublime místo notepadu.. V něm dej reopen with encoding.. Dej windows1250.. Zapiš si vše co chceš a pak to s tím ulož..

Edited by Cunoo (see edit history)
Link to post
  • 0
Posted (edited)
18 minutes ago, Cunoo said:

UTF8? For Czech?! xd

Try use brain...

Use charset windows1250 (Central European) and save as charset no instadead save..


Edit: CZ - UTF8 neumí diakritiku je to mezinárodní univerzal.. Musíš použít charset co jsem ti napsal a před zápisem prvně otevři locale_string.txt - já používám sublime místo notepadu.. V něm dej reopen with encoding.. Dej windows1250.. Zapiš si vše co chceš a pak to s tím ulož..

Toto už jsem zkoušel s více editorama a nic se nezměnilo, akorát to ve hře začalo psát korejský znaky
Tak nevím jak, ale nakonec se to rozjelo :D

Edited by GoldCash
SOLVED - THX Cunoo & joint4 (see edit history)
Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


×
×
  • Create New...

Important Information

Terms of Use / Privacy Policy / Guidelines / We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.