Jump to content
  • We need you!

    You must register to discover all the features of our community!

  • 0

Source problems after upgrade!!!


ALF

Question

  • VIP
Posted (edited)

Hey Metin2dev

 

We have upgraded the source so that i can compile it in Upper newest version of Freebsd 12.1 32 bits but  i got this error 

 

When i put the "game" and "db" in my files on VPS Freebsd 12.1 64 bits  it`s giving me this error 

ld-elf32.so.1: Shared object "libcryptopp.so.8" not found, required by "game"

 

I already Run  " pkg install cryptopp " and still same error 

 

2nd , I upload my serverfiles on Freebsd 12.1 32 bits and i got  " game.core" in  cd / usr/game/Auth 

and after do gdb i got this on Core 

 

spacer.png

 

When i try to Login in my server still here 

 

spacer.png

 

 

My  " db" and "game " Compile fine but i got those  errors

 

Thanks for u help please 

Edited by AleXE (see edit history)

" Don`t pretend things change if you always do the same thing"

"Don`t give up on a dream for how long it will take, time will pass the same"

Link to post

2 answers to this question

Recommended Posts

  • 0
  • VIP

Solved please closed 

" Don`t pretend things change if you always do the same thing"

"Don`t give up on a dream for how long it will take, time will pass the same"

Link to post
  • 0

1st make sure you always use the correct libraries. Your dev system is freebsd 12.1 32 bit, your production enviroment is 12.1 64 bit. If you install cryptopp via pkg on your production system you'll also get the 64 bit libraries, NOT 32 bit. Your 32 bit application cannot use these libraries.

2nd I highly recommend you using rpath as a linker option to specify a directory where you load your libraries from (e. g. /usr/local32/metin2).

3rd After building your game db, run ldd for both of them. Doing so will reveal all the locations of your libraries on the dev system. You can just download and upload them on your production server in the correct direcoty (see rpath).

4th Your game won't start without the correct libs to load. Obviously you cannot login if the server doesn't even start

5th Your problem may have occured now due to the fact that your libs have changed after upgrading. Remember: always keep the libs you need in sync.

 

Not to mention: DO NOT OVERWRITE LIBS. Make sure you have a special directory (see above rpath) and do not overwrite system libraries.

 

 

And finally 6th: If you solved your issue, post a solution for other members. Don't be selfish.

We are the tortured.
We're not your friends.
As long as we're not visible.
We are unfixable.

Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


  • Current Donation Goals

  • Activity

    1. 11

      Mysql56 to Mysql8

    2. 0

      Does anyone have Kami-Sama's Contact?

    3. 1

      [Trailer][1/3]NerviL2 The return of the Legend

    4. 0

      Won " price" change

    5. 10

      Inferna - The new "metin3"?

    6. 6

      We need you!

    7. 2

      Highlight system bug

  • Recently Browsing

    No registered users viewing this page.

×
×
  • Create New...

Important Information

Terms of Use / Privacy Policy / Guidelines / We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.