Jump to content
  • We need you!

    You must register to discover all the features of our community!

  • 0

Unbugging defensewave_pawn?


TMP4
Go to solution Solved by sxvoyz,

Question

The defensewave_pawn monster's animations does not work for some reason. They're doing damage but they only play the wait animation.

I just can't figure out what is wrong.

 

I took the files from: 

(Or reup just the defensewave_pawn: https://www66.zippyshare.com/v/P6GJ2WE7/file.html )

 

Proto:

3950    ë‚�ę°€    PAWN    MONSTER    MELEE    97    0    AGGR,BERSERK    0    ICE,ATT_ICE    TERROR    0    defensewave_pawn    0    95    64    63    31    168    252    19407    10    5    0    0    0    141    100    100    100    2000    100    0    0    0    0    0    0    3    15    15    15    10    15    15    15    15    0    0    0    0    2.000000    0    20    0    0    0    0    0    0    0    0    0    0    0    0    0    0    0    0    0
3951    ë‚�ę°€    PAWN    MONSTER    MELEE    97    0    AGGR,BERSERK    0    ICE,ATT_ICE    TERROR    0    defensewave_pawn    0    95    64    63    31    168    252    20407    10    5    0    0    0    141    100    100    100    2000    100    0    0    0    0    0    0    3    15    20    20    15    20    20    20    15    0    0    0    0    2.000000    0    20    0    0    0    0    0    0    0    0    0    0    0    0    0    0    0    0    0
3952    ë‚�ę°€    PAWN    MONSTER    MELEE    97    0    AGGR,BERSERK    0    ICE,ATT_ICE    TERROR    0    defensewave_pawn    0    95    64    63    31    168    252    21407    10    5    0    0    0    141    100    100    100    2000    100    0    0    0    0    0    0    3    15    25    25    15    25    25    25    15    0    0    0    0    2.000000    0    20    0    0    0    0    0    0    0    0    0    0    0    0    0    0    0    0    0

 

There's no syserr. Any idea?

Edited by TMP4 (see edit history)
Link to post

3 answers to this question

Recommended Posts

  • 0
  • Solution

Change in defensewave_pawn/motlist.txt

 

From

GENERAL SPECIAL normal_attack1.msa 100

To

GENERAL NORMAL_ATTACK normal_attack1.msa 100

 

///

Or set 100% chance to use skill by this monster

Link to post
  • 0
Posted (edited)

"Or set 100% chance to use skill by this monster"

 

Ah i see, there's no normal attack, it should use skills every time.

Do you know how to set the 100% skill use chance?

Edited by TMP4 (see edit history)
Link to post
  • 0
1 minute ago, TMP4 said:

"Or set 100% chance to use skill by this monster"

 

Ah i see, there's no normal attack, it should use skills every time.

Do you know how to set the 100% skill use chance?

gzdlbkf.png

 

add condition here like "if (GetRaceNum() == 101) return true;" before number expr

Link to post
Guest
This topic is now closed to further replies.


×
×
  • Create New...

Important Information

Terms of Use / Privacy Policy / Guidelines / We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.