Jump to content
  • 0

Stun/ Faint bug


CrazyBear

Question

Hello guys,

I need help, i want to make the faint resistance 90 or 95%, i haven't changed anything in gamefile , and been told that it comes 90 by default.. but idk why , it doesn't seem that

Another problem is when mages do their skills ( Lightning ) , the vs player get a 2-4 minutes faint...

How can it be resolved?

Thanks

Link to comment
  • Answers 3
  • Created
  • Last Reply

Top Posters For This Question

Popular Days

Top Posters For This Question

3 answers to this question

Recommended Posts

  • 0
bool CHARACTER::IsImmune(DWORD dwImmuneFlag)
{
	if (IS_SET(m_pointsInstant.dwImmuneFlag, dwImmuneFlag))
	{
		int immune_pct = 90;
		int	percent = number(1, 100);

		if (percent <= immune_pct)	// 90% Immune
		{
			if (test_server && IsPC())
				ChatPacket(CHAT_TYPE_PARTY, "<IMMUNE_SUCCESS> (%s)", GetName()); 

			return true;
		}
		else
		{
			if (test_server && IsPC())
				ChatPacket(CHAT_TYPE_PARTY, "<IMMUNE_FAIL> (%s)", GetName());

			return false;
		}
	}

	if (test_server && IsPC())
		ChatPacket(CHAT_TYPE_PARTY, "<IMMUNE_FAIL> (%s) NO_IMMUNE_FLAG", GetName());

	return false;
}

change immune_pct integer with 95 and try

 

Best Regards

Ellie

Do not be sorry, be better.

Link to comment
  • 0
  • VIP

Hello guys,

I need help, i want to make the faint resistance 90 or 95%, i haven't changed anything in gamefile , and been told that it comes 90 by default.. but idk why , it doesn't seem that

Another problem is when mages do their skills ( Lightning ) , the vs player get a 2-4 minutes faint...

How can it be resolved?

Thanks

It doesn't seem that because of the inmune bug: inmune only works if the shield is the last equipped item. I think there is a thread about this somewhere around the forum.

 

About the long faint - this happens when using the Skill Duration leadership skill.

 

 

 

Link to comment
  • 0

bool CHARACTER::IsImmune(DWORD dwImmuneFlag)
{
	if (IS_SET(m_pointsInstant.dwImmuneFlag, dwImmuneFlag))
	{
		int immune_pct = 90;
		int	percent = number(1, 100);

		if (percent <= immune_pct)	// 90% Immune
		{
			if (test_server && IsPC())
				ChatPacket(CHAT_TYPE_PARTY, "<IMMUNE_SUCCESS> (%s)", GetName()); 

			return true;
		}
		else
		{
			if (test_server && IsPC())
				ChatPacket(CHAT_TYPE_PARTY, "<IMMUNE_FAIL> (%s)", GetName());

			return false;
		}
	}

	if (test_server && IsPC())
		ChatPacket(CHAT_TYPE_PARTY, "<IMMUNE_FAIL> (%s) NO_IMMUNE_FLAG", GetName());

	return false;
}

change immune_pct integer with 95 and try

 

Best Regards

Ellie

 

Thank you very much,

I currently don't work with source, is there any diff for that?

Thanks

 

 

Hello guys,

I need help, i want to make the faint resistance 90 or 95%, i haven't changed anything in gamefile , and been told that it comes 90 by default.. but idk why , it doesn't seem that

Another problem is when mages do their skills ( Lightning ) , the vs player get a 2-4 minutes faint...

How can it be resolved?

Thanks

It doesn't seem that because of the inmune bug: inmune only works if the shield is the last equipped item. I think there is a thread about this somewhere around the forum.

 

About the long faint - this happens when using the Skill Duration leadership skill.

 

 

Ah okay i get it , but can we change that, the skill duration i mean maybe make it a little more smaller

Thank you

Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


×
×
  • Create New...

Important Information

Terms of Use / Privacy Policy / Guidelines / We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.