Jump to content
  • 0

Quest doesn't refresh after ./qc


Corviinho

Question

Hey community, i have a big problem.

 

 

When i put a quest at my quest directory and i cd & ./qc her, it doesn't create a folder on item "70021", it used to create but on every quest that i edit after multiple times it stops refreshing and stays like before (after editing like... 3 times).

What could be the problem?

 

I'm testing the Ezio 40k files.

Link to comment

9 answers to this question

Recommended Posts

  • 0

It sounds like permission problem.

chown -R youruser:youruser /home/game/or_whatever_yourfiles_are

If you run the server as root (what is highly NOT recommended) then i don't know what's wrong.

$ uptime
1:26AM  up 732 days,  8:29, 1 user, load averages: 0.38, 0.31, 0.22

$ uname -srp
FreeBSD 9.1-RELEASE amd64

Link to comment
  • 0

It sounds like permission problem.

chown -R youruser:youruser /home/game/or_whatever_yourfiles_are

If you run the server as root (what is highly NOT recommended) then i don't know what's wrong.

 

chown -R root:root /home/game/ 

 

?

Link to comment
  • 0

As i've wrote: if you are root than i don't know what is the problem.

 

Anyway if you run the game from /home/game, then you should run it as user "game".  And then: chown -R game:game /home/game

$ uptime
1:26AM  up 732 days,  8:29, 1 user, load averages: 0.38, 0.31, 0.22

$ uname -srp
FreeBSD 9.1-RELEASE amd64

Link to comment
  • 0

As i've wrote: if you are root than i don't know what is the problem.

 

Anyway if you run the game from /home/game, then you should run it as user "game".  And then: chown -R game:game /home/game

 

The quest directory is at:

/usr/home/game/share/locale/romania/quest 

 

I open the server by a shortcut "sh iniciar" that i wrote for "cd usr/home/game && sh start.sh"

 

 

So i write the "chown -R game:game /home/game" in the machine?

 

 

Sorry, i'm kinda of a noob :D

Link to comment
  • 0
  • Former Staff

nah ... he can edit it 3 times and after that the quest after editing will be the same without change

 

i recommend you to delete "70021"folder or whatever and

in game

/reload q

 

and try to ./qc the quest again

 

Link to comment
  • 0

 

As i've wrote: if you are root than i don't know what is the problem.

 

Anyway if you run the game from /home/game, then you should run it as user "game".  And then: chown -R game:game /home/game

 

The quest directory is at:

/usr/home/game/share/locale/romania/quest 

 

I open the server by a shortcut "sh iniciar" that i wrote for "cd usr/home/game && sh start.sh"

 

 

So i write the "chown -R game:game /home/game" in the machine?

 

 

Sorry, i'm kinda of a noob :D

 

chown -R youruser:youruser /home/game 

 or via filezilla just give permission 777 to all files (some need 775 but it wont be a problem and give

more or less some quest does not work after qc some needs reboot and some needs only (via gm /reload q) then login again and evrything should be okey

Link to comment
  • 0

nah ... he can edit it 3 times and after that the quest after editing will be the same without change

 

i recommend you to delete "70021"folder or whatever and

in game

/reload q

 

and try to ./qc the quest again

 

 

Already tried it, it won't work.

 

 

 

 

As i've wrote: if you are root than i don't know what is the problem.

 

Anyway if you run the game from /home/game, then you should run it as user "game".  And then: chown -R game:game /home/game

 

The quest directory is at:

/usr/home/game/share/locale/romania/quest 

 

I open the server by a shortcut "sh iniciar" that i wrote for "cd usr/home/game && sh start.sh"

 

 

So i write the "chown -R game:game /home/game" in the machine?

 

 

Sorry, i'm kinda of a noob :D

 

chown -R youruser:youruser /home/game 

 or via filezilla just give permission 777 to all files (some need 775 but it wont be a problem and give

more or less some quest does not work after qc some needs reboot and some needs only (via gm /reload q) then login again and evrything should be okey

 

 

I'll give it a try, thanks.

 

 

 

 

 

#Edit:

All premissions on 777

 

 

 

chown -R root:root /home/game 

chown -R game:game /home/game

chown -R root:root /usr/home/game

chown -R game:game /usr/home/game

 

Tried all of this, nothing worked.... idk why, gives an error (chown:root: Invalid argument)

Link to comment
  • 0

then do make sure tht you add the quest in proper and perfect way :

1- upload your quest to the quest folder usualy on this path :

/home/game/share/locale/yourlocale/quest/
or
/usr/home/game/share/locale/yourlocale/quest/

change your locale with your locale name //ex. germany

and give permession 777 using filezilla/winSCP

then on putty/Vbox //ssh

cd to your quest folder then comply the quest and here is a sample :

cd /home/game/share/locale/germany/quest
./qc fullquestname.quest

replace fullquestname.quest with your quest name

you can use a python tool like make

or .sh file like make.sh to comply all of the quest //i recommend using python tool

all what you need is too add it to locale list or quest list //just read your make file its easy ^^

then with a GM character with all permission use

/reload q

log-out and log-in again
and the quest should work how ever some time the same quest does not work with the same character 2 time so test it with another

good luck

  • Love 1
Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


×
×
  • Create New...

Important Information

Terms of Use / Privacy Policy / Guidelines / We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.