Jump to content
  • 0
displayjokes

open Summon Monsters Near Block/Walls

Question

Hey, i was trying to summon monsters near walls (where there's block), and the monster does not summon, i tried with quests, /m command and regen files, the monster does not spawn near walls, any idea on how to fix this please?

I've been searching and can't find anything.

Thanks in advance

Share this post


Link to post

5 answers to this question

Recommended Posts

  • 0

You can only summon a monster at a coordinate that can kill / hit you, if it is within the village or in a location that cannot be hit, it does not come. It is a safety of the game itself, but useless, because if you release nearby monster, it ends up going after the characters.

Share this post


Link to post
  • 0
17 hours ago, Klaus said:

You can only summon a monster at a coordinate that can kill / hit you, if it is within the village or in a location that cannot be hit, it does not come. It is a safety of the game itself, but useless, because if you release nearby monster, it ends up going after the characters.

Yeah, i noticed that, but i made a dungeon that has walls (with block), near each other and i wanted to summon a metin within the zone that you can hit the monster, but it won't summon, that's why i want to get rid of this thing..

 

Any idea on how to do it?

Share this post


Link to post
  • 0

Maybe it will help you a little bit 😓

LPCHARACTER CHARACTER_MANAGER::SpawnMob(DWORD dwVnum, long lMapIndex, long x, long y, long z, bool bSpawnMotion, int iRot, bool bShow)

and

LPCHARACTER CHARACTER_MANAGER::SpawnMobRandomPosition(DWORD dwVnum, long lMapIndex)


in char_manager.cpp in source game

  • Love 1

Share this post


Link to post
  • 0

It's not a bug, it's a feature. They made it that way with a purpose.

If you enable attack in a sectree with ATTR_BLOCK / ATTR_BANPK you need to to enable damage in that area, that means people can attack in the safezone.

Easy fix for you: open the map in world editor and try to remove ATTR_BLOCK / ATTR_BANPK in the area you need to spawn monsters.

Share this post


Link to post
  • 0
On 9/13/2019 at 8:56 PM, Nirray said:

Maybe it will help you a little bit 😓


LPCHARACTER CHARACTER_MANAGER::SpawnMob(DWORD dwVnum, long lMapIndex, long x, long y, long z, bool bSpawnMotion, int iRot, bool bShow)

and


LPCHARACTER CHARACTER_MANAGER::SpawnMobRandomPosition(DWORD dwVnum, long lMapIndex)


in char_manager.cpp in source game

Thank you will try that!

 

11 hours ago, Johnny69 said:

It's not a bug, it's a feature. They made it that way with a purpose.

If you enable attack in a sectree with ATTR_BLOCK / ATTR_BANPK you need to to enable damage in that area, that means people can attack in the safezone.

Easy fix for you: open the map in world editor and try to remove ATTR_BLOCK / ATTR_BANPK in the area you need to spawn monsters.

I do not have block in the area i want to spawn mobs, i have like a hall, something like the monkeys cave from the oficial, but instead of walls, had mountains with block 😕

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...

Important Information

Terms of Use / Privacy Policy / Guidelines / We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.