Jump to content
  • 0

Mysql error


R3laX

Question

Hello,

I got the problem that i get this message from Navicat : 1130 - host ' MY IP ' is not allowed to connect to this mysql server. its Hamachi please help

 

 

~Sorry for bad english 

 

 

To fix the error : 

 

you just have to login in the cmd in mysql an just run this commands 

 

GRANT ALL PRIVILEGES ON *.* TO 'root'@'%' Enter drücken

IDENTIFIED BY 'your pw' WITH GRANT OPTION;

Link to comment
  • Answers 5
  • Created
  • Last Reply

Top Posters For This Question

Top Posters For This Question

5 answers to this question

Recommended Posts

  • 0
  • Bot
mysqladmin -u root -p yourpass
mysql -u root -p
Enter your pass
GRANT ALL PRIVILEGES ON *.* TO [email protected]"%"
IDENTIFIED BY 'your_pass' WITH GRANT OPTION;
quit
 
check this
 
 
otherwise
run
ee /usr/local/etc/rc.d/mysql-server
 
change mysqluser="mysql" to  mysqluser="root"
 
Link to comment
  • 0

 

mysqladmin -u root -p yourpass
mysql -u root -p
Enter your pass
GRANT ALL PRIVILEGES ON *.* TO [email protected]"%"
IDENTIFIED BY 'your_pass' WITH GRANT OPTION;
quit
 
check this
 
 
otherwise
run
ee /usr/local/etc/rc.d/mysql-server
 
change mysqluser="mysql" to  mysqluser="root"

 

 

Quote: Only if you have mysql.sock problem.

Link to comment
  • 0
  • Former Staff

 

check if the port is open O.o

 

hamchi doesnt need to open port in most of the cases

 

 

 

yeah i know 

but the i think you need to open the port for the sql at least

cus my server is hamachi and i can't open sql without the port :)

Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


×
×
  • Create New...

Important Information

Terms of Use / Privacy Policy / Guidelines / We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.