Jump to content
  • 0

[HELP] 64bit FreiBSD


CrazyBear

Question

Hello metin2devs :) , i already got a server with 64bit freibsd installed it , 

when i try to run the server im getting this error :  http://prntscr.com/3x2coh

 

and i already got the lib for db_notxt.so 

 

thats my start.sh script :

case $chs in 
1*) 

	echo -e "033[31m Database Acýlýyor ..033[0m"
	cd /usr/game/db
	env LD_PRELOAD="/usr/game/share/dblib/db_notxt.so" ./db &
	sleep 2
	clear
	echo -e "033[31m n Giris Aciliyor ..033[0m"
	cd /usr/game/auth 
	./auth &
	sleep 2
	clear
	echo -e "033[31m n 1.Kanal Aciliyor ..033[0m"
	cd /usr/game/channel1
	env LD_PRELOAD="/usr/game/share/gamelib/kickhackfix.so" ./game &
	sleep 2
	clear
	echo -e "033[31m n Game99 Aciliyor ..033[0m"
	cd /usr/game/game99
	env LD_PRELOAD="/usr/game/share/gamelib/kickhackfix.so" ./game &
	sleep 2
	clear

can anyone help me please ? :) 

Link to comment
  • Answers 6
  • Created
  • Last Reply

Top Posters For This Question

Top Posters For This Question

6 answers to this question

Recommended Posts

  • 0

First:

env LD_32_PRELOAD="/usr/game/share/dblib/db_notxt.so" ./db &

Second:

env LD_32_PRELOAD="/usr/game/share/gamelib/kickhackfix.so" ./game &

And after this the two libs will work properly.

Link to comment
  • 0

First:

env LD_32_PRELOAD="/usr/game/share/dblib/db_notxt.so" ./db &

Second:

env LD_32_PRELOAD="/usr/game/share/gamelib/kickhackfix.so" ./game &

And after this the two libs will work properly.

LD_32 isnt lib32 file ? 

im trying to run the game on 64 bit 

Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


×
×
  • Create New...

Important Information

Terms of Use / Privacy Policy / Guidelines / We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.