Jump to content

Search the Community

Showing results for tags 'bonus'.

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • Metin2 Dev
    • Announcements
    • Pillory
    • Praises / Complaints
    • Feedback / Suggestions
  • Community
    • Member Representations
    • Off Topic
    • Games Talk
    • Music / Videos / Art
  • Metin2
    • General
    • Private Servers
  • Help Area
    • Questions & Answers
  • Releases
    • Special forum during backup
    • Guides & HowTo
    • Binaries & Clients / ServerFiles
    • Programming & Scripts / Systems
    • Tools
    • Maps
    • Quests
    • 3D Models
    • 2D Graphics
    • Operating Systems
  • Temporary
    • Temporary

Categories

There are no results to display.

There are no results to display.

Blogs

There are no results to display.

There are no results to display.


Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


Status


Nationality


Kingdom


Skype


Discord


Website


Mapping


Music / Audio


3D


2D


C++


C#


C


LUA


Python


PHP


SQL


HTML


CSS


JavaScript


Java


FreeBSD


Windows

  1. Hello, I want to ask you guys. I recently added Aura System, I dont even know the release name. Its like 70% official, but now Im struggling with the values of absorption. But then, we realized, that it will be better for our server to set fixed values (apply_something) on each item and we will not use the absorption just like official does. But I have problem, when I try to set values via item_proto = its not working. Can you please tell me what file should I eddit? Because there is maybe some collision there, right? Thanks in advance.
  2. Hello community, can you help me please how to edit displayed bonuses in jewelry when you add an ore? I added 3 bonuses into earings, and when I add ore, there are displayed only 2. Works all 3 of them, but they are not in the description as you can in in the picture. https://imgur.com/gallery/t2oDhH3 I did not find anything like that. Thank you and sorry for my english.
  3. Hello metin2dev. I have a problem, per 10% mobs bonus on item, you get like 300 damage in +. How can I change that damage per % added? I searched the entire forum for this and I couldn't find it. Could never be more happier if anybody could guide me into what I need to do. I searched the game src, db src, the db itself but with no success, I didn't find any bonuses related to the damage it gives per %. Example > 10% mobs on costume gives 300 damage + I want 10% mobs on costume to give 800 damage+ Thanks a lot for reading. Hope you can help me!
  4. I'm having an issue with the 6/7 bonus items. No syserr by the client or the server regarding the issue. You can see the bug below in the video I don't think there is something wrong with the proto records but here they are for any case: 71051 bonus_adder+ ITEM_USE USE_SPECIAL 1 ANTI_DROP | ANTI_SELL | ANTI_STACK LOG | STACKABLE NONE NONE 1000000 0 0 0 0 LIMIT_NONE 0 LIMIT_NONE 0 APPLY_NONE 0 APPLY_NONE 0 APPLY_NONE 0 0 0 0 0 0 0 0 0 0 71052 bonus_changer+ ITEM_USE USE_SPECIAL 1 ANTI_DROP | ANTI_SELL | ANTI_STACK LOG | STACKABLE NONE NONE 500000 0 0 0 0 LIMIT_NONE 0 LIMIT_NO
  5. The bonus of the Sash is shown wrong, but it give's me the right bonus. Also i have a problem with reversal certificate: i tried this one : https://metin2dev.org/board/index.php?/topic/9251-pythonsash-resetting-scroll-fix/#comment-56451 but i doesn't work...
  6. Hi Guys! I think you didn't see similar before because my problem is too rare (I googled for solution, and I searched a lot to solve it at similar forums). So the problem is when you add bonuses to your weapon (or something else), and you go to another map or you simply log out, the bonus will disappear. But if you put into your safebox, or you drop the thing to the ground, the bonus is still remain in your item, so I think the problem is somehow "attached" to the player's inventory. I maded a video from it, you can see it what am I talking about: I have two systems i
  7. Hi all! I'm trying to do a bonus page inside the character window but with more pages. For example one player has to press C or V or B or N, then left click on 'BONUS' (on the right of 'QUEST') and then he can click on various buttons inside the bonus page. If I put only 1 page with no other buttons in the bonus page it works, but if I try to insert them it gives me the error: uiCharacter.py(line:424) __LoadWindow uiCharacter.py(line:161) __LoadScript ui.py(line:2854) LoadScriptFile ui.py(line:3072) CheckKeyList CharacterWindow.__LoadWindow - <type 'exceptions.At
  8. Hello, I have Mount costume system. When I log off while sitting on a mount and then login in, my apply bonuses are x2. There is only 1 bonus in affect, but that mount bonus gives me bonus x2. Quest: Could you help me, please? Thanks.
  9. Hello, I have a strange problem, I have 10 bonus (5 normal, 5 rare), EVERYTHING works, really EVERYTHING, but the item_attr_rare-table used only lv5, when I switched, item get only max bonus only 4.000 HP, 1.000 SP, 12 STR/INT/DEX/CON works Syserr is empty. item_attr (normal) is fully worked, no problems. maybe this helps: I copied item_attr and named it item_attr_rare. Maybe the structure is broken. When I change MAX_HP body to 4, ingame switched 2.000 HP, when I changed body 3, ingame switched 1.000 HP (only this) Can someone help, please?
  10. Hello guys! I would like to ask you, how its possible to disable 6/7 by some function in C++ I heard its not that hard and its possible, but I dont have idea. Just make the function which will make 6/7 bonus not working for the moment when its ON. Thank you for any help!
  11. Hey guys, is it possible to add a second bonus to any item in the blend.txt? Currently it looks like just one is possible, same for the potion , when i add a second bonus only the first is getting applied. Is there any way to chance that or am i doing something wrong?
  12. I got a problem with the new pet system when I summon a new pet, the pet give me random half human bonus I don't understand why if someone could help me fix it to put this bonus to 0 so when the pet is summoned it give 0 half human bonus. I tried everything and after some research I found that the problem may come from those files, but I don't know where to search exactly ! Please some help would be great-full New_PetSystemcpp.txt New_PetSystemh.txt
  13. Hi guys, can someone tell me where I can find a value of bonus of skill Fear on WP sura? Thanks for answers! Sincerely, ReFresh
  14. Hey! How can i add bonus for mounts, what is give the bonus in my inventory, in the c++? THANK YOU!
  15. Hello, I have a question. How can i add simple "new" bonus like "strong vs metinstones/boss-monster" It's important for me. =) Thank you.
  16. It's been quite a while for now that i can't figure out the cause of this problem, As you can see in the gif below, the added bonuses to the sash stay on top of the base bonuses which is a big problem for the certificate of reversal (sash bonus removal), plus it looks ugly. Now i've been looking around and it looks like it may be comming from the item_proto itself because when I use my older version of the proto it shows up correctly. I do think it's a problem with the dump_proto, maybe the structure is not right, so I went to check and i think everything looks fine for the sash, beside
  17. Hello, someone know about the old change-bug with 1-5 bonus by equip-item i already fix 1-5 bonus, but how can i fix 6/7 bonus adder/changer? with this fix is 6/7 not fixed. thank you. question2: limittype8 or 9 (i dont know anymore) give the item a time-value. the time is running only when the item is equip like EXP-Ring, thieves gloves, costume, costume-mount, dragon-soul etc. how can i add the limittype8 function for items like pet/mounts = (type18/questitem)? question3: how can i add +-10 lvl for the skill-function. example: sura lvl 15 cannot debuff
  18. P.S: Feel free to give opinions, leave comments, critique, test and review. Explanation: The quest gives items with full bonuses and stones, example of the items in table below: Credits: C++ Functions - here LUA - Marius Exygo Quest download: Download link here HiHi Requirements: 40k game source item.set_attribute - quest_list(server side) pc.give_item2_select - quest_list(server side) item.set_socket - quest_list(server side) C++ Functions - here More info: Shaman items list is not fin
  19. Hello guys I have a problem I don't know how to get costume weapon items to have bonus. I searched any potential function in the source but no luck so can somebody help me please? Thanks in advance
  20. Hello guys.. Can anyone help me with this? >x< x: I need add to weapon more than 3 bonuses.. I don't want to put the bonuses from: applytype0-applytype2, applyvalue0-applyvalue3. Beacuse i can't use more than 3 bonuses, and i need 3+. Any ideas?
  21. Hi experts, i'm USING Maxmi 4.1 and having problem with 6/7 bonus I check my char_item.cpp <spoiler> case 71051 : // 진재가 { // 유럽, 싱가폴, 베트남 진재가 사용금지 if (LC_IsEurope() || LC_IsSingapore() || LC_IsVietnam()) return false; LPITEM item2; if (!IsValidItemPosition(DestCell) || !(item2 = GetInventoryItem(wDestCell)))
  22. Hello! I managed to install Mijagos Bonus Switcher to my client, and this appeared on my sysser. The client stuck on loading screen! Can anybody help?
  23. Hello guys I followed MrLybia's tut about making 6 normal bonus to items https://metin2dev.org/board/index.php?/topic/8471-chowto-6norm-attr-2-rare/ and now I'm trying to update my Switchbot but I don't actually know what to edit... Here is my switchbot.py
  24. Hello guys I just noticed a problem that many of you may have with 6/7 attributes and may have ever noticed of it. When I change the 6/7 attributes it changes the bonuses but they come always on their 5th level from the table player.item_attr_rare (ex. if Max HP has lv1 = 200, lv2 = 250, lv3 = 350, lv4 = 400 and lv5 = 500 it fetches only 500). I really need your help on this guys please if anybody has a tip that can help share it below thanks Also if you can help me with this topic I'd appreciate thanks again https://metin2dev.org/board/index.php?/topic/9457-new-resist-flag-for-mob_p
  25. Hello folks i need a little help from u !! THis is the quest i use . quest Turkey begin state start begin when 52011.use begin pc.mount ( 20120 , 28800 ) pc.mount(20120, 60*60*24*365) pc . mount_bonus ( apply . ATTBONUS_ATT_BONUS_TO_MONSTER , 25 , 28800 ) pc . mount_bonus ( apply . ATTBONUS_ATT_SPEED , 20 , 28800 ) end end end The quest compile fine but i dont get the bonus ingame Tryed to input bonus with numbers same . Anyone have some idea ?
×
×
  • Create New...

Important Information

Terms of Use / Privacy Policy / Guidelines / We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.